NPC's not executing script

Learn about OpenMW mod compatibility, check for problematic mods, discuss issues, and give us feedback about your experience with modded OpenMW.
Post Reply
User avatar
Zobator
Posts: 62
Joined: 23 Nov 2014, 19:35

NPC's not executing script

Post by Zobator » 08 Mar 2018, 17:56

Currently I'm working on a mod for a slightly improved chargen. https://www.nexusmods.com/morrowind/mods/45510

For some reason, the orcs, argonians and imperials do not execute the scripts they have attached in OpenMW. They do so in vanilla MW. What's going on?

Chris
Posts: 1500
Joined: 04 Sep 2011, 08:33

Re: NPC's not executing script

Post by Chris » 08 Mar 2018, 18:41

Is anything printed to the terminal or log? If a script doesn't execute that generally means it failed to compile, which should cause something to be printed to the terminal/log.

User avatar
Zobator
Posts: 62
Joined: 23 Nov 2014, 19:35

Re: NPC's not executing script

Post by Zobator » 08 Mar 2018, 19:12

Chris wrote:
08 Mar 2018, 18:41
Is anything printed to the terminal or log? If a script doesn't execute that generally means it failed to compile, which should cause something to be printed to the terminal/log.
I indeed get error-messages for the unexecuted scripts, which are all similar:

Code: Select all

error ZobCharGenBoatOrc line [last line of the script], column 4 (end)
    Unexpected keyword
Warning: compiling failed: ZobCharGenBoatOrc
Not sure what causes this though. I've been looking at those scripts many times, but can't find what makes them different from the ones that do work...

User avatar
AnyOldName3
Posts: 1120
Joined: 26 Nov 2015, 03:25

Re: NPC's not executing script

Post by AnyOldName3 » 08 Mar 2018, 19:53

Maybe someone here could work it out if you posted them. It's also possible that the CS can point out the issue.
AnyOldName3, Master of Shadows

User avatar
Zobator
Posts: 62
Joined: 23 Nov 2014, 19:35

Re: NPC's not executing script

Post by Zobator » 08 Mar 2018, 23:36

Figured it out through the OpenMW CS. Apparently copy-pasted a 'else if', which compiles in vanilla, but doesn't in OpenMW.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests