Page 1 of 2

Fixes for Uvirith's Legacy

Posted: 21 Jul 2017, 10:22
by Xandaros
Hey there,

Uvirith's Legacy is one of my favourite mods and it works pretty well in OpenMW. Unfortunately, there are a couple things that don't work out properly.
In another thread, Stuporstar has already announced that UL 4.0, if it comes, will have better support for OpenMW.
In the meantime, though, I made a little add-on that fixes some things.

I know there were more issues and I will fix them as I find them. You will have to wait for me to progress to those points in the mod or fix it yourself :P
Note that these changes are not vanilla-compatible, which is why it will be distributed as .omwaddon instead of .esp.

  • 1.2:
    • The beds in the upper tower are less shiny
  • 1.1:
    • The ancient tomes are now usable
    • The book "Secrets of Dwemer Containment" now gives you the journal entry when read from the inventory, as well. Not just when read from the ground.
    • Similarly, the scroll you need to read to enchant the Bag of Holding can now be read from the inventory, as well
  • 1.0:
    • Inscription ritual can be activated by reading the scrolls
    • The beds in the lower tower are less shiny
Other known problems:
  • The teleport ring does not work 0.41. This is an engine bug. The best option to fix this would be to compile OpenMW from source. If you don't want to do that for some reason, you could also downgrade to 0.40. If that is also not an option, you will have to wait for 0.42.

Re: Fixes for Uvirith's Legacy

Posted: 21 Jul 2017, 23:31
by Stuporstar
Thanks for taking on this project. I probably won't be further updating UL 3.5, but I'll be keeping track of all these OpenMW fixes to make UL 4.0 compatible.

Re: Fixes for Uvirith's Legacy

Posted: 03 Aug 2017, 20:13
by Bonehurtingjuice
Thank you Xandaros for the patch, and thanks to Stuporstar for pointing me to this thread!

I will play a lot of UL tonight and will try to list every "white" texture objects here.

The Teleport Ring does function properly in 0.42, if it's the Uvirith teleport you mean. First I thought it doesn't, but then I saw the Travel option in the services window.

Re: Fixes for Uvirith's Legacy

Posted: 03 Aug 2017, 20:24
by Bonehurtingjuice
So, the first little thing is the Fine Silver Letter Opener, see screenshot.
Texture for Chaise is missing as well.

Don't worry, I won't spam with every single find, just thought I'd throw that one in already since it's the only two things I noticed after looking through the tower the first time.

Re: Fixes for Uvirith's Legacy

Posted: 03 Aug 2017, 20:46
by Stuporstar
Yeah, the letter opener is too shiny because it needs its reflection and normal maps stripped. I'm not sure what else needs it in UL 3.5, but there are a lot of meshes I need to strip in UL 4.0. I'm not sure what's going on with the chaise lounge, but the magenta definitely means it's either missing the texture or OpenMW doesn't like something about the nif's texture path.

I'm happy to hear the travel ring creature is offering its services properly. I should probably also mention OpenMW isn't letting disabled NPCs/creatures use force greetings, which may break a few things in my mod and others. That was the problem Xandaros worked around to make the spell tomes work again.

As for the reported problems with the tower lift collision, we're going to have to test it with an updated mesh that has the proper collision nodes and flags, as there's specific flags you need to set up to make moving objects update their collision every frame, and I'm not sure yet how well OpenMW will handle it. I'll have more on that later.

Re: Fixes for Uvirith's Legacy

Posted: 03 Aug 2017, 22:31
by Xandaros
Well, I did explicitly mention that the travel ring will work in 0.42 :P

The chalice is working perfectly fine for me, so maybe it's a problem with your installation? I have to say, though, that my openmw installation is rather messed up. Tribunal is an absolute mess, almost all meshes are missing in Mournhold...

Didn't notice the letter opener before, I'll see if I can fix it.
I'll also update to 0.42 to see if maybe that causes the chaise problem. (I was using a home-compiled version before because of the travel ring)

The lift does cause me to fall through it, but I honestly never use it anyway. Levitating is so much faster :P
Don't worry, I won't spam with every single find
If you find something, collect it and at the end of your playing session tell us, so I can get the fix in sooner :P

Edit: Chaise is fine: Image

Edit2: No clue what to do with the letter opener, sorry :(

Re: Fixes for Uvirith's Legacy

Posted: 03 Aug 2017, 23:33
by Bonehurtingjuice
So far so good.

Weirdly enough, after loading your patch, the chaise was completely fine, although you didn't even intend to fix it, you did apparently :D
However, the beds are just as shiny golden as they were before. I will try to take my mesh replacer out of the loadout and see if that's the issue (thanks, OpenMW, for the brilliant built-in Mod Organiser! Loving it!)

Bag of Holding is working perfectly. Only a very minor issue; prior to enchanting the bag (with Aryon's scroll) it has the form of a magenta cuboid.

Went to Divayth Fyr for the alchemy table and to activate his platform. Getting the Ouvulus (sorry if I butchered it) out of the egg works fine, will finish that stuff tomorrow.
However, there's something wrong with the Puzzle Box. Fyr doesn't recognise that the box is in my possession. He continues to say "We'll talk once you get the box." Using the little riddle to open it works, but after the message that I've opened it successfully, nothing happens. No inventory popup, and no item added to my inventory (I forgot what it does, to be honest, all I remember is that Fyr is more pleased with you if you admit to tinkering with it).

Ring of Servitude is working great. It doesn't work while the apprentice is busy with chores, but I suppose that is intended.

I'm sure that I put my two Cursed Daedric pages into one of the chests in the secret lab prior to advancing to Archmagister. After finishing the stronghold (Vault and some Upper Tower additions, but you know that), the pages were gone. Does storage reset during building your stronghold? Either that or I put them somewhere else and forgot it. Stupid me. player->additem "what do I put here?" It was Ogrim and... bah, I don't even remember the second page. Whatever.

Not sure if that's what you mean with ForcedGreet, but the Telvanni Guards on the third floor do not greet me when I pass by. I miss the double overlapping "Archmagister of House Telvanni" bursting into my ears. :)

Re: Fixes for Uvirith's Legacy

Posted: 03 Aug 2017, 23:39
by Xandaros
I really think your load order is messed up...

The ForceGreeting thing is actually what prevents the ring of servitude to work while the apprentice is away. It's meant to work.

This is a bug in OpenMW, though and there's not really anything I can do about it. (Not without a huge workaround, at least)

Re: Fixes for Uvirith's Legacy

Posted: 03 Aug 2017, 23:43
by Bonehurtingjuice
Uvirith's Legacy 3.51
Your patch
UL TR Patch
UL RoHT Patch

These are the last plugins loaded. But why do you think that? Because of the Puzzle Box bug?

Removing my mesh replacer did not fix the glowing beds.

Giving Fyr the Puzzle Box / Message worked just fine, it was me being incredibly stupid. I didn't see Yagrum's note popping into my inventory, and kept selecting the "Telvanni Teleport" topic instead of the "Dwemer Puzzle Box" one. Are you still okay with me testing stuff? Haha :D

However, now Qorwynn doesn't want the Ouvulas. I took the Ouvulas out of the egg, have a Grand Soul Gem with a Winged Twilight Soul, and Fyr's scroll in my inventory, but Qorwynn keeps telling me that I'm wasting his time.

Another Edit:
Using "Set uvi_QhasSoul to 1" has taken care of that. And even when it didn't say so in the dialogue window, he still correctly took the soul gem. That little problem might have been caused by me using a custom Twilight Summon spell, because I'm too bad to recognise if you included that in your script.

Re: Fixes for Uvirith's Legacy

Posted: 07 Aug 2017, 02:39
by Bonehurtingjuice
Everything runs smoothly so far, just minor issues:

When Almossaren is going for his first assignment (when he's waiting for you in the storage) and you wait there for 2 days, he'll be back, but it will still be his almossaren_wait version without a selectable "recent shipments" topic. Leaving the storage, waiting 24 hours and coming back fixes this.

He sits a couple yards high in the air instead of on the chair. Screenshot attached. RA puts him back onto his chair, but then some weird physics cause him to pop up into the air again. It's probably OpenMW's weird collision issues. TCG shows the full ugliness of the situation :D