Uvirith's Legacy problems

Learn about OpenMW mod compatibility, check for problematic mods, discuss issues, and give us feedback about your experience with modded OpenMW.
lambda
Posts: 21
Joined: 11 Sep 2016, 17:10

Re: Uvirith's Legacy problems

Post by lambda » 17 Jan 2017, 14:59

Bessarion wrote:Is anyone else having an issue where the player falls through the upper tower elevator platform when it rises? Going down works fine, just not going up.
Yes. I played a little more and have the third stage complete and there are some weird glitches going on. Going up on the elevator, it seems I collide somewhere that prevents me going up while the elevator keeps going up -- presumably going *through* me. Weirder still, is that when I enter the upper tower, tcl seems to randomly turn on (have not yet found a pattern to it).

None of these issues are fatal though. I just send the elevator to the bottom floor and levitate everywhere. And when I enter the upper tower, if I start sinking through the ground, then I know it is time to bring up the console and type tcl.

User avatar
sjek
Posts: 407
Joined: 22 Nov 2014, 10:51

Re: Uvirith's Legacy problems

Post by sjek » 17 Jan 2017, 20:06

https://bugs.openmw.org/issues/2274

collision with big faces ie. vivec canton walls. that elevator might be one face with texture on it
selecting it while console and ori command should give you the nif file in question
"life is crazy"
"craziness has beauty which only crazies understand" some movie clip in the head.
https://wiki.openmw.org/index.php?title=Testing

User avatar
Bessarion
Posts: 7
Joined: 08 Nov 2016, 20:02

Re: Uvirith's Legacy problems

Post by Bessarion » 18 Jan 2017, 02:44

Apparently it's uvi_elev_hall_plug.nif

For what it's worth, it's a closed three-dimensional shape, not just a flat surface with no depth.

I haven't experienced the issue with TCL turning on, though. Aside from the elevator everything clips normally for me. This is on the 2.0 version of the mod, though -- possibly lambda is on a newer version? Textures in the current version don't render properly in OpenMW for me, but I'm not a fan of those non-stock textures anyway.

TheMechanist
Posts: 49
Joined: 10 Jan 2014, 22:08

Re: Uvirith's Legacy problems

Post by TheMechanist » 05 Mar 2017, 23:56

Does anyone else experience that the beds in the tower have golden reflection effects?

EDIT: Today I also got a crash:
Last thing in log:

Code: Select all

Loading cell Tel Uvirith, Tower Upper
warning line 180, column 23 (jo_TU_Communicator)
    Names for script jo_tu_Communicator do not match
warning line 64, column 6 (Endif)
    endif without matching if/elseif
Although this script seems to be releated to another mod
EDIT2: Sorry this crash seems to relate to some mesh fixing mod and not the script. I will open another thread for this.
Attachments
Golden Bed - Kopie.png

User avatar
sjek
Posts: 407
Joined: 22 Nov 2014, 10:51

Re: Uvirith's Legacy problems

Post by sjek » 06 Mar 2017, 16:29

Apparently it's uvi_elev_hall_plug.nif

For what it's worth, it's a closed three-dimensional shape, not just a flat surface with no depth.
well.. the elevator shown ingame is like a cookie but the RootCollisionNode defined in nif is box with two big triangles on the side of it.

Does anyone else experience that the beds in the tower have golden reflection effects?
can you use ori console command on said bed. that will show the cell, coordinates and model for it.
would suspect enviromental mapping / effect or some texture with channel used differently in vanilla.
"life is crazy"
"craziness has beauty which only crazies understand" some movie clip in the head.
https://wiki.openmw.org/index.php?title=Testing

TheMechanist
Posts: 49
Joined: 10 Jan 2014, 22:08

Re: Uvirith's Legacy problems

Post by TheMechanist » 22 Mar 2017, 19:14

Ok here is a screenshot with the ORI command
Attachments
screenshot010.png

User avatar
Capostrophic
Posts: 234
Joined: 22 Feb 2016, 20:32

Re: Uvirith's Legacy problems

Post by Capostrophic » 22 Mar 2017, 22:11

Yes, it's environment mapping. There's NiTextureEffect in the mesh.
shitty lingua anglica grammar ftw

Stuporstar
Posts: 5
Joined: 01 Jul 2017, 06:35

Re: Uvirith's Legacy problems

Post by Stuporstar » 18 Jul 2017, 19:08

Yeah, I mistakenly used MGSO 3.0's bed meshes instead of the originals when working on UL 3.0. The bump and reflection maps need to be stripped, which I've done for UL 4.0 (which is currently on hiatus due to an HDD crash unfortunately).

Future versions of my mods are going to take OpenMW fully into account, so please feel free to report any bugs you find.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest