Page 5 of 6

Re: Older bump mapped mods (and how to make them work in Ope

Posted: 30 Apr 2017, 21:11
by Aramithius
How do I attach files? I don't see any option in the post settings.

Re: Older bump mapped mods (and how to make them work in Ope

Posted: 30 Apr 2017, 21:46
by Amenophis
Hello, after all that trouble with On the Rocks, I just renamed the textures of the mod and made tottaly compatible with OpenMW (Without the need of nifs - Just textures with the OpenMW way). Please test.
https://www.dropbox.com/s/dln34vvtbrvui ... 29.7z?dl=0

I recommend use along Correct UV rocks v1.0 by Nicholiathan http://mw.modhistory.com/download-31-12003
and WIP Detailed Correct UV Rocks by Pherim http://www.nexusmods.com/morrowind/mods ... 4321&pUp=1

Re: Older bump mapped mods (and how to make them work in Ope

Posted: 01 May 2017, 06:17
by Capostrophic
Erm, but... The whole point of the mod is replacing meshes...

Re: Older bump mapped mods (and how to make them work in Ope

Posted: 01 May 2017, 09:58
by Aramithius
Having purged all the original On the Rocks textures and meshes, those work, but only alongside Correct UV Rocks and WIP Detailed Correct UV Rocks. That's good enough for me for now.

Re: Older bump mapped mods (and how to make them work in Ope

Posted: 01 May 2017, 13:09
by Amenophis
Capostrophic wrote:Erm, but... The whole point of the mod is replacing meshes...
I've found that On the Rocks meshes have problems with vanilla cave entrances and big incompatibilities with TR. So, because of this I took this approach (all textures renamed to vanilla scheme).

Two more:
1 - Lougian Bloodmoon Caverns Bump Mapped https://www.dropbox.com/s/i6iw8ot7mdkui ... 29.7z?dl=0

2 - Lougian Caverns Bump Mapped https://www.dropbox.com/s/rgbuxz1udw61m ... 29.7z?dl=0

Re: Older bump mapped mods (and how to make them work in Ope

Posted: 23 May 2017, 07:18
by TheOneWhoWatches
Just tried "On The Rocks".
At first I tried to delete NiNode>NiNode>NiTextureEffect branch and everything became fine, but then I tried another approach.
I just changed "Tad_rock_refl3.dds" and "Tad_rock_refl3.dds" to almost-black an shine were gone.
Well, almost gone. I wanted to have rocks slightly reflective. Just a tiny bit.

P.S. I didn't change normal maps' filenames or whatelse, seems it's working fine as it is.

P.P.S. ... and obviously I've found similar solution on nexus (although reflection maps are completely black there) after I posted about my own.
And if by chance this method was discussed here, then I apologize.

Re: Older bump mapped mods (and how to make them work in Ope

Posted: 22 Nov 2017, 22:23
by lysol
TheOneWhoWatches wrote:
23 May 2017, 07:18
Just tried "On The Rocks".
At first I tried to delete NiNode>NiNode>NiTextureEffect branch and everything became fine, but then I tried another approach.
I just changed "Tad_rock_refl3.dds" and "Tad_rock_refl3.dds" to almost-black an shine were gone.
Well, almost gone. I wanted to have rocks slightly reflective. Just a tiny bit.

P.S. I didn't change normal maps' filenames or whatelse, seems it's working fine as it is.

P.P.S. ... and obviously I've found similar solution on nexus (although reflection maps are completely black there) after I posted about my own.
And if by chance this method was discussed here, then I apologize.
I'll necro this because I somehow missed this post.

Well yes, the method you used works if you don't mind not having real normal maps. The method described in the tutorial is what I used when making this "patch" for the mod, so basically I removed the environment map effect (which is what makes the models shiny) and renamed some textures. The result is that you get real normal mapping instead of fake ones, or in this case, no normal maps at all.

Re: Older bump mapped mods (and how to make them work in OpenMW)

Posted: 01 Dec 2017, 09:11
by Vinditus
Thank you for this tutorial lysol.
It helped me greatly to make older mods look good in OpenMW.
While it work, I still have some errors in OpenMW log telling that some texture layers are empty, but without visual errors.
I'd like to know how to fix this, for the sake of correctness.
Could anyone please tell me what I'm doing wrong ?

A screenshot:

https://imgur.com/yFXkupG

Thank in advance.

Re: Older bump mapped mods (and how to make them work in OpenMW)

Posted: 01 Dec 2017, 11:11
by lysol
No problem! Glad people can follow the tutorial with success.

I can't check the zip file you uploaded right now, but I would guess that you've kept some blocks in the nif files linking to some textures that you've renamed or removed or something like that. So if you had a normal map or specular map that weren't named in OpenMW fashion and then renamed them without removing the blocks linking to them in the nif file, you would probably get errors because the nif file is trying to find them but can't (since they have been renamed).

Just my guess...

Re: Older bump mapped mods (and how to make them work in OpenMW)

Posted: 01 Dec 2017, 15:10
by akortunov
A well-known issue. That's because you deleted the bump maps, but your NiTexturingProperty nodes have "Has Bump Map Texture" enabled.
This warning is harmless.