Page 1 of 1

Urvel Dulni Won't Follow

Posted: 22 Feb 2016, 04:03
by ghales
The Morrowind “Shrine of the Dead” quest has a known problem with Urvel Dulni occasionally stopping and not following the player. Evidently, his script is broken. The UESP Wiki gives a number of simple ways to get him started again, which have worked for me in Morrowind.

Unfortunately, in OpenMW, none of these methods work. Urvel stopped moving on me just outside the shrine. I tried everything the wiki suggested. He just stood there looking at me. I also left the area, and re-entered. I saved and re-loaded, and I ~RAd him (which caused him to disappear completely). Finally, I ~PlaceatPCd him, which gave me a second Urvel who cleansed the shrine, as he was supposed to. The new Urvel even followed me out, past the first Urvel still standing there.

The log gave this, when I tried to tell him to “Follow Me”:

Loading cell Old Mournhold: Temple Shrine
warning line 6, column 17 (GetDisabled)
Ignoring extra argument
Playing music/explore/mx_explore_7.mp3
AiFollow: player, 0, 0, 0, 0
AiFollow: player, 0, 0, 0, 0
AiFollow: player, 0, 0, 0, 0
Quitting peacefully.

Obviously, you can't fix a broken Morrowind script, but is it possible to fix the simple workaround of talking to Urvel and telling him to follow you whenever he stops? Is there a better solution than creating a second Urvel? BTW, is that how PlaceatPC is supposed to work?