Page 3 of 3

Re: Application: Sailanarmo

Posted: 09 Apr 2019, 16:25
by Sailanarmo
What will be the plan moving forward then?

Re: Application: Sailanarmo

Posted: 09 Apr 2019, 16:59
by AnyOldName3
Discussion on Discord has revealed that we're okay to drop Qt4 support. That means the plan is to:
  • Apply the upstream osgQt changes to our version (or apply our changes to the upstream version - as long as we end up with the upstream changes and our changes in the version in our repo, it doesn't matter how it's achieved) and confirm that the threading workaround is no longer necessary.
  • Change any other stuff that lets Qt4 work, such as changing the minimum version requirement in CMake.