Page 4 of 38

Re: OpenMW 0.45.0

Posted: 07 Sep 2018, 14:21
by Capostrophic
Is it time to feed OpenMW to Coverity one more time?

Re: OpenMW 0.45.0

Posted: 08 Sep 2018, 10:24
by Zini
Done.

Re: OpenMW 0.45.0

Posted: 16 Sep 2018, 12:13
by akortunov
Maybe ask Atahualpa to slowly start working on 0.45 videos?

Re: OpenMW 0.45.0

Posted: 16 Sep 2018, 12:32
by Capostrophic
And ask raevol to start honing the changelog while we're at it, or there won't be a release until Christmas. :P

(I'm not entirely against that. There's no need to rush with this release.)

Re: OpenMW 0.45.0

Posted: 17 Sep 2018, 08:42
by raevol
Capostrophic wrote:
16 Sep 2018, 12:32
And ask raevol to start honing the changelog while we're at it, or there won't be a release until Christmas. :P
Yea, I meant to start early on this one, but what with starting my grad classes, that didn't happen. Fingers crossed!

Re: OpenMW 0.45.0

Posted: 23 Sep 2018, 11:17
by Atahualpa
akortunov wrote:
16 Sep 2018, 12:13
Maybe ask Atahualpa to slowly start working on 0.45 videos?
Well, exams are just around the corner which is why I'm going to be busy for another three weeks. Meanwhile, I expect you to hit the 200 mark. :P

Re: OpenMW 0.45.0

Posted: 24 Sep 2018, 10:28
by Zini
That's actually not bad timing. Let's tentatively schedule the begin of the RC phase three weeks from now.

Re: OpenMW 0.45.0

Posted: 24 Sep 2018, 13:28
by lysol
Soooooo shadow merge soon? :roll:

Re: OpenMW 0.45.0

Posted: 24 Sep 2018, 14:47
by AnyOldName3
On my local copy there are just a few issues left:
  • I've sort-of fixed what I've been describing as Evil Flicker, but it's been replaced by the Windows equivalent of a segfault in the terrain system. I should be able to work out why it's happening, but things have got weird (for example, when I run the same build of OpenMW with a debugger, it's now a gazillion times slower, despite me never having had that issue before). The good news is that in an emergency, I can just hide the terrain shadows setting in the merge and neither bug will ever show up.
  • Lots of OpenGL errors are spat out, and they don't make sense to me when viewed in APITrace. I think maybe OSG isn't combining statesets correctly or we're doing something it doesn't like. I can't really suppress this, but release builds don't have the system console show up, so most users won't see the error messages, so it's maybe not a deal-breaker.
  • I can't (or couldn't when I tried a few months ago, even with Scrawl's help) reliably get shadow map rendering to do anything differently to regular rendering, which means I can't do anything to stop actors with an invisibility effect showing up in the shadow map. This might well also be because OSG isn't doing what I think I'm asking it to do and almost certainly has the same root cause as the above issue. If we don't care about people who are supposed to be invisible casting shadows, this is fine, though.

Re: OpenMW 0.45.0

Posted: 25 Sep 2018, 22:50
by Thunderforge
AnyOldName3 wrote:
24 Sep 2018, 14:47
I can't (or couldn't when I tried a few months ago, even with Scrawl's help) reliably get shadow map rendering to do anything differently to regular rendering, which means I can't do anything to stop actors with an invisibility effect showing up in the shadow map. This might well also be because OSG isn't doing what I think I'm asking it to do and almost certainly has the same root cause as the above issue. If we don't care about people who are supposed to be invisible casting shadows, this is fine, though.
My opinion is that this should not block merging the shadow feature (or version 1.0 for that matter). If vanilla does not have shadows for invisible characters, then file a separate bug for it.