Page 25 of 26

Re: OpenMW 0.45.0

Posted: 09 Feb 2019, 00:38
by psi29a
Something for the issue tracker, not for 0.45 :)

Re: OpenMW 0.45.0

Posted: 09 Feb 2019, 00:39
by AnyOldName3
There's no way to add a page that displays the licence as a hack (e.g. as if it were an optional component to choose to install)?

Re: OpenMW 0.45.0

Posted: 10 Feb 2019, 20:42
by faerietree
Ace wrote:At the moment, if you want to do anything more than the default installer then it requires modifying CMake itself and writing new NSIS installer scripts, which I'd prefer to not do. (I did so earlier to remove the license page entirely, but updates keep messing that up)
Yes please no superfluous workload only because _one_ person ever complained about "OK" vs. "Agree". A wise man knows what to ignore. And really, we could as well define "Agree" := "OK" somewhere in the text and use the plain simple existing functionality.

Re: OpenMW 0.45.0

Posted: 13 Feb 2019, 21:55
by K1ll
Here's a new set of Linux targz package RCs:

32 Bit
64 Bit

Re: OpenMW 0.45.0

Posted: 13 Feb 2019, 23:20
by corristo

Re: OpenMW 0.45.0

Posted: 14 Feb 2019, 23:16
by testman
64bit RC2 for Linux starts and runs fine. 👍

I also ran RC2 for macOS inside macOS VM, and it does appear to be running normally if I load some game.
It is probably the issue with whole thing being in VM, but in both 0.44.0 release and in RC2 the intro part with Juib and guard does not work properly for me.
No mouth animations, name prompt does not appear, guard comes but then stops moving, player never gets control over character movement.
But like I said, this is most likely an non-issue, as environment is not exactly as it were on Apple computers.

Re: OpenMW 0.45.0

Posted: 15 Feb 2019, 01:04
by halcyon
The macOS RC2 worked fine for me on an iMac, including chargen and more playtesting than I should probably have done on a work night. The CS also runs and browsed through scripts and objects in a couple of plug-ins without problems.

Re: OpenMW 0.45.0

Posted: 15 Feb 2019, 06:27
by akortunov
testman wrote:
14 Feb 2019, 23:16
No mouth animations, name prompt does not appear, guard comes but then stops moving, player never gets control over character movement.
But like I said, this is most likely an non-issue, as environment is not exactly as it were on Apple computers.
Probably because VM fails to find sounds for some reason, so chargen scripts fail. There should be error messages in log.

Re: OpenMW 0.45.0

Posted: 15 Feb 2019, 08:26
by raevol
Sounds like we need Windows RCs (and testing for them) and a status update on the video and announcement? I think Atahualpa was proofreading the announcement?

Re: OpenMW 0.45.0

Posted: 15 Feb 2019, 11:41
by Husaco
raevol wrote:
15 Feb 2019, 08:26
Sounds like we need Windows RCs (and testing for them) and a status update on the video and announcement? I think Atahualpa was proofreading the announcement?
Ace (SWE) wrote:
07 Feb 2019, 21:42
Built up some new Windows RCs then;

32-bit
64-bit
They didn't break with light testing for me.