OpenMW 0.45.0

Anything related to PR, release planning and any other non-technical idea how to move the project forward should be discussed here.
terabyte25
Posts: 38
Joined: 26 Jul 2018, 12:58
Github profile: https://github.com/terabyte25

Re: OpenMW 0.45.0

Post by terabyte25 » 20 Oct 2018, 03:52



User avatar
Zini
Posts: 5528
Joined: 06 Aug 2011, 15:16

Re: OpenMW 0.45.0

Post by Zini » 20 Oct 2018, 09:14

@Atahualpa We are going ahead with the release. We just need to fix this one last blocker and then I will start the RC phase.

User avatar
raevol
Posts: 2786
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: OpenMW 0.45.0

Post by raevol » 20 Oct 2018, 09:59

Haha, well that's what happens when someone who writes the code does the changelog I guess. :)

User avatar
akortunov
Posts: 435
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation
Github profile: https://github.com/akortunov

Re: OpenMW 0.45.0

Post by akortunov » 23 Oct 2018, 20:15

terabyte25 wrote:
20 Oct 2018, 03:30
Okay, so I tried looking for when this appeared, and it appeared all the way back in late June. It started when macOS support was broken (OpenMW client didn't launch) June 20th(OpenMW-20062018-22eb037) all the way to June 28th(OpenMW-28062018-f07d50e). I believe it was the either the commit that broke macOS support, or the commit that fixed macOS support that caused this regression to pop up.
Weird. It this period there were a lot of CI and dependency changes.
For example, we started to use the 10.13 SDK for Mac OS.
I suppose we need an actual bisect to find out what exactly causes the issue.

terabyte25
Posts: 38
Joined: 26 Jul 2018, 12:58
Github profile: https://github.com/terabyte25

Re: OpenMW 0.45.0

Post by terabyte25 » 24 Oct 2018, 00:03

akortunov wrote:
23 Oct 2018, 20:15
terabyte25 wrote:
20 Oct 2018, 03:30
Okay, so I tried looking for when this appeared, and it appeared all the way back in late June. It started when macOS support was broken (OpenMW client didn't launch) June 20th(OpenMW-20062018-22eb037) all the way to June 28th(OpenMW-28062018-f07d50e). I believe it was the either the commit that broke macOS support, or the commit that fixed macOS support that caused this regression to pop up.
Weird. It this period there were a lot of CI and dependency changes.
For example, we started to use the 10.13 SDK for Mac OS.
I suppose we need an actual bisect to find out what exactly causes the issue.
What would be the best commit to check first?

Also I am having problems with compiling in macOS in the meantime, I'll see to it I get it compiling correctly.

User avatar
akortunov
Posts: 435
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation
Github profile: https://github.com/akortunov

Re: OpenMW 0.45.0

Post by akortunov » 26 Oct 2018, 09:04

It seems weapon condition indicator is broken.

User avatar
akortunov
Posts: 435
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation
Github profile: https://github.com/akortunov

Re: OpenMW 0.45.0

Post by akortunov » 26 Oct 2018, 10:00

Probably an another regression: https://gitlab.com/OpenMW/openmw/issues/4694

User avatar
wareya
Posts: 229
Joined: 09 May 2015, 13:07

Re: OpenMW 0.45.0

Post by wareya » 26 Oct 2018, 10:07

That might be specific to whatever Bullet build the OpenMW OSX nightlies are being compiled against.
paying attention to #1751 #2473 #3609 #3862/#3929 #3807 #4297 #4623

User avatar
akortunov
Posts: 435
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation
Github profile: https://github.com/akortunov

Re: OpenMW 0.45.0

Post by akortunov » 26 Oct 2018, 11:08

wareya wrote:
26 Oct 2018, 10:07
That might be specific to whatever Bullet build the OpenMW OSX nightlies are being compiled against.
Or more likely it is just a regression in this commit.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests