Page 16 of 28

Re: OpenMW 0.44.0

Posted: 19 Jun 2018, 15:03
by psi29a
raevol wrote:
15 Jun 2018, 09:15
Windows RCs: tested
You sure this has been 'tested'?

https://gitlab.com/OpenMW/openmw/issues/4445

It's pretty crap that we'll be releasing builds that don't work for some people.

Re: OpenMW 0.44.0

Posted: 19 Jun 2018, 15:39
by AnyOldName3
We've not been able to reproduce it when other people have tested, and even NullCascade hasn't been able to when a debugger has been attached.

Re: OpenMW 0.44.0

Posted: 19 Jun 2018, 15:53
by psi29a
According to him, it only happens on release builds including the latest RC build. He can't reproduce it locally when he builds everything from scratch. His builds work, ace's apparently did not. I don't believe his is lying so I think it prudent that more people test the windows build. More testing couldn't hurt right?

Re: OpenMW 0.44.0

Posted: 19 Jun 2018, 16:06
by Lagahan
psi29a wrote:
19 Jun 2018, 15:53
According to him, it only happens on release builds including the latest RC build. He can't reproduce it locally when he builds everything from scratch. His builds work, ace's apparently did not. I don't believe his is lying so I think it prudent that more people test the windows build. More testing couldn't hurt right?
I'll give the latest RC a couple hours of play tonight, in case it crops up over time. Could run it on my Surface to give it less resources to work with, though nullcascades machines seem to be pretty well specced.
Can't play anything too brain intensive anyway have to fix a pc for someone :P

Re: OpenMW 0.44.0

Posted: 19 Jun 2018, 19:38
by Ace (SWE)
NullCascade, could you maybe try building up some release binaries using the CI script, with the LTO build flag enabled in the CMake options, see if that still results in the same issue?

If those too show the issue then it might be worth looking over doing some gentler optimization - though it'll lose us performance.

Re: OpenMW 0.44.0

Posted: 20 Jun 2018, 00:13
by NullCascade
Ace (SWE) wrote:
19 Jun 2018, 19:38
NullCascade, could you maybe try building up some release binaries using the CI script, with the LTO build flag enabled in the CMake options, see if that still results in the same issue?

If those too show the issue then it might be worth looking over doing some gentler optimization - though it'll lose us performance.
I won't be able to get to this for another couple of weeks. I'm out of town.

Re: OpenMW 0.44.0

Posted: 20 Jun 2018, 02:54
by l1lartur0
Used the RC for about a week until I replaced it with Monday's (18.06) nightly build (e93104a6b3). Probably clocked around 12-14 hours on the RC build and 3 hours on the nightly build without rendering or any other issues for me, at least. Just in case any of the following info could be of use...

Specs: Windows 7 Ultimate 64-bit, Intel i7-4770k, 16 GB RAM, Samsung EVO 860 500 GB SSD, Nvidia GTX 750 Ti

Settings.cfg:
Spoiler: Show
OpenMW.cfg (game ran with mods installed):
Spoiler: Show
OpenMW.cfg (new game started today; test run across Vvardenfell for nearly two hours; no mods):
Spoiler: Show
EDIT: Feh. Dealing with a respiratory infection and a bit more scatterbrained than usual due to the meds (well, that's my excuse, anyway... ). I had also meant to submit the log file from today's playthrough with the new game. Failed to save the log and has been overwritten. As I stated, don't know if any of this info will be of any use pertaining to the potential rendering issue for the Windows builds, so if not, I do apologize for cluttering up the thread with this post. Best of luck and take care.

Re: OpenMW 0.44.0

Posted: 20 Jun 2018, 07:56
by Zini
Looks like tackling the Windows issue isn't on the table for 0.44.0 (since we won't get more relevant testing any time soon). This is a long standing issue that only affects a limited amount of users and I don't see it as a blocker. Seems the blocker is actually the lack of an MacOS build.

Re: OpenMW 0.44.0

Posted: 20 Jun 2018, 09:25
by Zini
0.45.0 is already at 50 closed issues, more than half what 0.44.0 has. We are catching up to you guys. Run! Run!

Okay, just kidding.

Re: OpenMW 0.44.0

Posted: 20 Jun 2018, 09:28
by psi29a
Zini wrote:
20 Jun 2018, 09:25
0.45.0 is already at 50 closed issues, more than half what 0.44.0 has. We are catching up to you guys. Run! Run!

Okay, just kidding.
When do we start the RC for 0.45? :lol: