OpenMW 0.40.0

Anything related to PR, release planning and any other non-technical idea how to move the project forward should be discussed here.
Holgar
Posts: 18
Joined: 28 Aug 2016, 02:04

Re: OpenMW 0.40.0

Post by Holgar » 01 Sep 2016, 23:51

Well, I'm not the one telling those great guys what they have to code.

openMW 0.40 has arrived on ubuntu launchpad. Thank You!!

So I think, it's released now.

Would be nice,if you could announce on your site here as well:
http://openmw.org/en/

If you need some help for Public Relation may be we can come together.

Here you are
http://forum.worldofplayers.de/forum/th ... r-erwartet

Once more. Thank you for your great work.

User avatar
Atahualpa
Posts: 1044
Joined: 09 Feb 2016, 20:03

Re: OpenMW 0.40.0

Post by Atahualpa » 02 Sep 2016, 20:41

Holgar wrote: Would be nice,if you could announce on your site here as well:
http://openmw.org/en/
raevol will post the official release announcement once he has everything in place to do so. -- And enough time, I guess.
Holgar wrote: If you need some help for Public Relation may be we can come together.

Here you are
http://forum.worldofplayers.de/forum/th ... r-erwartet

Once more. Thank you for your great work.
Thanks for spreading the word. A bit of exterior discussion is always good. (Although Pherim and you are obviously members of our forums. :) )

User avatar
raevol
Posts: 3015
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: OpenMW 0.40.0

Post by raevol » 02 Sep 2016, 21:10

Hi all- three things.

First, sorry for the delay in responses. I sit in my room for weeks with nothing to do while the release comes together, and then as soon as things are shaping up, real life jumps out and throttles me.

Second:
K1ll wrote:Also OSG does print errors to the console when it can't load a module because of a missing dependency so there is an indication that something went wrong and how to fix it. Anyway maybe we should add to the release notes that Qt4 and libpng12 are required to use the targz package binaries.
I understand all of these words, but I don't understand the issue here well enough to confidently write something and release. From my uneducated standpoint it still looks like the Linux Binary packages are built incorrectly, and need to be fixed before we can release. If this is not the case, please write some text for me to include in the release announcement, as my hackish attempt at writing this is only going to cause confusion.


Third:
Holgar wrote:So I think, it's released now.

Would be nice,if you could announce on your site here as well:
http://openmw.org/en/
We have a well-established release process, and we are currently *not* released. Because of the difficulty of having to coordinate different release vectors between different people on different places on the planet, sometimes the debian packages end up in the hands of users before the release actually hits. That's ok, it's just part of the game. But it doesn't mean we're released yet.

Holgar
Posts: 18
Joined: 28 Aug 2016, 02:04

Re: OpenMW 0.40.0

Post by Holgar » 03 Sep 2016, 00:17

Holgar wrote: If you need some help for Public Relation may be we can come together.

Here you are
http://forum.worldofplayers.de/forum/th ... r-erwartet

Once more. Thank you for your great work.
Thanks for spreading the word. A bit of exterior discussion is always good. (Although Pherim and you are obviously members of our forums. :) )
As for myself: *Guest* here and simply reading the forums while trying to understand what's going on.

~Holgar

€dit: Could you please comment on this: Your code is compiled by Canonical and underway via update. Existing on launchpad.

There is a problem with security key where apt-get complains about.

Hey: before coding anymore, fix this. We need a clear message to the community.


You Are Out!

What's up?

User avatar
raevol
Posts: 3015
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: OpenMW 0.40.0

Post by raevol » 03 Sep 2016, 02:30

Holgar wrote:There is a problem with security key where apt-get complains about.
Your post would be a lot more helpful if you could copy/paste the error that you are getting?

User avatar
psi29a
Posts: 4637
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: OpenMW 0.40.0

Post by psi29a » 03 Sep 2016, 08:02

Holgar wrote:As for myself: *Guest* here and simply reading the forums while trying to understand what's going on.

~Holgar

€dit: Could you please comment on this: Your code is compiled by Canonical and underway via update. Existing on launchpad.

There is a problem with security key where apt-get complains about.

Hey: before coding anymore, fix this. We need a clear message to the community.


You Are Out!

What's up?
I do not like your tone and how you are bullying people into 'hurrying up' or demanding _anything_. Everyone here is a volunteer, doing what they can with what time they have. You are being warned, be nice and help instead.

If you would like, I can hold off updating the Ubuntu PPA until after the release is officially published. Canonical hosts the PPA infrastructure, but I'm the one who makes sure the packages are built and work properly. It would be a shame to have to have yet another 'staging' PPA, adding more work to the release process just to make you, and only you, happy.

As for the "There is a problem with security key where apt-get complains about.", then show what the problem is instead of talking about it. We can not help you otherwise. Address that first before making demands.

weedfreak
Posts: 54
Joined: 29 Jan 2016, 09:44

Re: OpenMW 0.40.0

Post by weedfreak » 03 Sep 2016, 08:28

0.40 is released on Arch, has been for a few days.

User avatar
psi29a
Posts: 4637
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: OpenMW 0.40.0

Post by psi29a » 03 Sep 2016, 08:37

weedfreak wrote:0.40 is released on Arch, has been for a few days.
That's the thing, we can't "control" that... It's open-source. The moment that Zini makes the tag, is the moment that package maintainers do their things and it makes it downstream. :)

We're still coordinating the actual release document, blog post and videos. This stuff takes time.

Just the way of life. :)

K1ll
Posts: 146
Joined: 06 Aug 2011, 21:54

Re: OpenMW 0.40.0

Post by K1ll » 03 Sep 2016, 10:38

raevol wrote: Second:
K1ll wrote:Also OSG does print errors to the console when it can't load a module because of a missing dependency so there is an indication that something went wrong and how to fix it. Anyway maybe we should add to the release notes that Qt4 and libpng12 are required to use the targz package binaries.
I understand all of these words, but I don't understand the issue here well enough to confidently write something and release. From my uneducated standpoint it still looks like the Linux Binary packages are built incorrectly, and need to be fixed before we can release. If this is not the case, please write some text for me to include in the release announcement, as my hackish attempt at writing this is only going to cause confusion.
Well to keep this short here is the text for the Release Notes:

Code: Select all

Note: To use the linux targz package binaries Qt4 and libpng12 must be installed on your system.

User avatar
Atahualpa
Posts: 1044
Joined: 09 Feb 2016, 20:03

Re: OpenMW 0.40.0

Post by Atahualpa » 03 Sep 2016, 11:11

weedfreak wrote:0.40 is released on Arch, has been for a few days.
Holgar wrote: You Are Out!

What's up?
I'm not the one in charge here but for me -- and probably most of the team members and users -- a release is done when raevol has posted the official release announcement. Until then there may be changes to certain, or even all, release builds.

Accordingly, v0.40.0 hasn't been released yet, and so haven't the release videos -- although some overzealous users posted the engine video's link on reddit.

Locked