OpenMW 0.40.0

Anything related to PR, release planning and any other non-technical idea how to move the project forward should be discussed here.
Locked
User avatar
Ace (SWE)
Posts: 830
Joined: 15 Aug 2011, 14:56

Re: OpenMW 0.40.0

Post by Ace (SWE) » 31 Aug 2016, 05:42

raevol wrote:Also currently waiting on word on the Linux and Windows binaries.
Well, several people have verified the 64-bit binary, haven't heard anyone mention the 32-bit one.

Anyone?
http://www.lysator.liu.se/~ace/OpenMW/r ... -win32.exe

Allofich
Posts: 104
Joined: 28 May 2016, 12:50

Re: OpenMW 0.40.0

Post by Allofich » 31 Aug 2016, 07:58

Seems fine for me. I can start OpenMW, the CS, the wizard and the launcher. I went in-game for a little bit in OpenMW and everything seemed fine.

User avatar
psi29a
Posts: 4677
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: OpenMW 0.40.0

Post by psi29a » 31 Aug 2016, 08:47

The problem with OSG-3.4 on the Ubuntu PPA has been worked around. We don't need to add anything to the release notes. It should be solved as people do `apt update`. Thanks to Shnatsel for that. :)

User avatar
raevol
Posts: 3042
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: OpenMW 0.40.0

Post by raevol » 31 Aug 2016, 16:38

@Ace thanks for the confirmation, sorry for the trouble.

Thanks Shnatsel, psi29a, regarding the packages. Now just waiting to hear from K1ll about the Linux binaries.
Atahualpa wrote:Ehm, I think scrawl meant "Fixed constant effects not to be put on hold when resting". :roll:
Sometimes I don't know how I even make it through life. Thanks scrawl, Atahualpa. Updated: https://gist.github.com/mickeylyle/602e ... /revisions

User avatar
augustt
Posts: 51
Joined: 14 Dec 2012, 17:14

Re: OpenMW 0.40.0

Post by augustt » 31 Aug 2016, 18:02

Shnatsel wrote:
psi29a wrote:Perhaps this is something to note in the release notes for Ubuntu PPA users that they need to first uninstall everything having to do openscenegraph first before install openmw-0.40?

viewtopic.php?f=2&t=3739&p=41683#p41680
NOOOOOOO

It's a bug in the Debian packaging! Here's a hotfix, add this to your debian/control for the "libopenscenegraph-3.4-130" binary package:

Code: Select all

Conflicts: libopenscenegraph-123
Replaces: libopenscenegraph-123
How do I do this? Not quite Linux literate enough to know where debian/control is.

Chris
Posts: 1562
Joined: 04 Sep 2011, 08:33

Re: OpenMW 0.40.0

Post by Chris » 31 Aug 2016, 18:06

augustt wrote:How do I do this? Nit quite Linux literate enough to know where debian/control is.
If you're not making the .deb packages, you don't. The people handling the PPA will do it (and it sounds like it's already done; you just need to update).

Tels
Posts: 21
Joined: 01 Jul 2016, 18:03
Contact:

Re: OpenMW 0.40.0

Post by Tels » 31 Aug 2016, 18:10

Chris wrote:
augustt wrote:How do I do this? Nit quite Linux literate enough to know where debian/control is.
If you're not making the .deb packages, you don't. The people handling the PPA will do it (and it sounds like it's already done; you just need to update).
Yep, there was an update to libopenscenegraph-3.4-130 today. Can't verify that it fixes the brokenpackage state, tho, as I already fixed it by removing -123 and re-installing openmw.

User avatar
augustt
Posts: 51
Joined: 14 Dec 2012, 17:14

Re: OpenMW 0.40.0

Post by augustt » 31 Aug 2016, 18:11

Chris wrote:
augustt wrote:How do I do this? Nit quite Linux literate enough to know where debian/control is.
If you're not making the .deb packages, you don't. The people handling the PPA will do it (and it sounds like it's already done; you just need to update).
My system is broken, I can't update anything.

Code: Select all

[email protected]:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  libopenscenegraph123
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
  libopenscenegraph-3.4-130
The following NEW packages will be installed:
  libopenscenegraph-3.4-130
0 upgraded, 1 newly installed, 0 to remove and 6 not upgraded.
5 not fully installed or removed.
Need to get 0 B/6,399 kB of archives.
After this operation, 31.6 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 261182 files and directories currently installed.)
Preparing to unpack .../libopenscenegraph-3.4-130_3.4.0+dfsg1-1~xenial3_amd64.deb ...
Unpacking libopenscenegraph-3.4-130:amd64 (3.4.0+dfsg1-1~xenial3) ...
dpkg: error processing archive /var/cache/apt/archives/libopenscenegraph-3.4-130_3.4.0+dfsg1-1~xenial3_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libosgTerrain.so.3.4.0', which is also in package libopenscenegraph123:amd64 3.4.0-1+xenial1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for libc-bin (2.23-0ubuntu3) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libopenscenegraph-3.4-130_3.4.0+dfsg1-1~xenial3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
edit: nevermind, I purged openmw* and then reinstalled!

K1ll
Posts: 146
Joined: 06 Aug 2011, 21:54

Re: OpenMW 0.40.0

Post by K1ll » 31 Aug 2016, 18:19

raevol wrote:@Ace thanks for the confirmation, sorry for the trouble.

Thanks Shnatsel, psi29a, regarding the packages. Now just waiting to hear from K1ll about the Linux binaries.
IIRC I'm intentionally leaving out libpng because there was a problem with the system Qt4 picking up the bundled libpng library even though it depends on the systems libpng version. Means neither the launcher nor openmw-cs were able to run even though Qt4 was available. Most distros (including Fedora) have a separate libpng12 Package and after installing that the binaries do run fine.

Also OSG does print errors to the console when it can't load a module because of a missing dependency so there is an indication that something went wrong and how to fix it. Anyway maybe we should add to the release notes that Qt4 and libpng12 are required to use the targz package binaries.

User avatar
MrAnonGuy
Posts: 42
Joined: 26 Aug 2016, 01:21

Re: OpenMW 0.40.0

Post by MrAnonGuy » 31 Aug 2016, 22:59

K1ll wrote: IIRC I'm intentionally leaving out libpng because there was a problem with the system Qt4 picking up the bundled libpng library even though it depends on the systems libpng version. Means neither the launcher nor openmw-cs were able to run even though Qt4 was available. Most distros (including Fedora) have a separate libpng12 Package and after installing that the binaries do run fine.

Also OSG does print errors to the console when it can't load a module because of a missing dependency so there is an indication that something went wrong and how to fix it. Anyway maybe we should add to the release notes that Qt4 and libpng12 are required to use the targz package binaries.
Greetings,

Are there specific reasons that you are building against libpng 1.2 and Qt4? I'm a Fedora user and in OM V0.39, and now in V0.40, I used Qt5 and libpng 1.6 when building the binaries. Everything seemed to work OK, but maybe I just didn't realize there were issues. Is there code that requires these older packages, or can the new versions of Qt and libpng be used without issues?

I'm wondering if I should rebuild using the older packages?

Thanks!

Locked