OpenMW 0.34.0

Anything related to PR, release planning and any other non-technical idea how to move the project forward should be discussed here.
Chris
Posts: 1558
Joined: 04 Sep 2011, 08:33

Re: OpenMW 0.34.0

Post by Chris » 14 Dec 2014, 16:33

sjek wrote:found this Q§A from august
http://www.yosoygames.com.ar/wp/2014/08 ... final-faq/
Yes, that makes sense. DX10 and GL3 (core profile) work in a way rather different to previous versions. Lots of fixed-function stuff is removed and specific programmability features are required, and the best way to take advantage of that programmability is to not worry about needing fixed-function fallbacks due to missing features.

DX10 and GL3 are roughly equivalent, when it comes to hardware requirements. The Geforce 8000-series is the oldest from nVidia to support the DX10/GL3 feature-set (I don't know what the equivalent AMD cards are, unfortunately).

User avatar
scrawl
Posts: 2152
Joined: 18 Feb 2012, 11:51

Re: OpenMW 0.34.0

Post by scrawl » 14 Dec 2014, 16:42

Regarding the increased hardware requirements, I already talked about that on my blog. My take on it is that an older branch supporting Ogre 1.x can always be maintained, if there is enough interest.
Anyway, these changes to Ogre 2.0 increasing the requirements aren't even released yet, for all we know this may not affect openmw for years to come, so there's no need to panic.

corristo
Posts: 493
Joined: 12 Aug 2011, 08:29

Re: OpenMW 0.34.0

Post by corristo » 14 Dec 2014, 20:10

One annoying OpenCS issue fixed: #2212, I think this should be added to the changelog.
#2191 still requires further investigation, so let's add it to known issues.

User avatar
Zini
Posts: 5536
Joined: 06 Aug 2011, 15:16

Re: OpenMW 0.34.0

Post by Zini » 15 Dec 2014, 09:12

#2212 was a 0.34.0 regression, right? We do not add these to the changelog.

corristo
Posts: 493
Joined: 12 Aug 2011, 08:29

Re: OpenMW 0.34.0

Post by corristo » 15 Dec 2014, 09:29

I don't think so. It was Ogre bug, which was here since first OpenCS release with rendering support.

User avatar
raevol
Posts: 3000
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: OpenMW 0.34.0

Post by raevol » 15 Dec 2014, 10:18

Hi guys, checking in. I see there's more stuff for me to sort through, will definitely do that. Tomorrow is the first day of my final, and Tuesday is the second. Sorry I have to delay things a little, but I should be able to get this all sorted by the end of the week. I haven't sorted through all the posts here in detail yet, so if there is anything other than cleaning up the changelog that is an outstanding issue for the release, please bring it to everyone's attention.

User avatar
Zini
Posts: 5536
Joined: 06 Aug 2011, 15:16

Re: OpenMW 0.34.0

Post by Zini » 16 Dec 2014, 11:30

No problem, but we definitely should get the release done this week, because I won't be available next week.

I think we are more or less ready. If nothing else comes up I will give the go for the final release builds in a day or two and than we can have the release on Friday or Saturday.

User avatar
raevol
Posts: 3000
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: OpenMW 0.34.0

Post by raevol » 16 Dec 2014, 20:08

Sounds good. Headed to my final in a few minutes, and will try to get to the release tomorrow. Psi29a will you be around at work? <3

Edit: And by "tomorrow" I mean "when Zini oks the final build release".

User avatar
Zini
Posts: 5536
Joined: 06 Aug 2011, 15:16

Re: OpenMW 0.34.0

Post by Zini » 17 Dec 2014, 15:07

Alright then. Tag has been applied. Go!

K1ll
Posts: 146
Joined: 06 Aug 2011, 21:54

Re: OpenMW 0.34.0

Post by K1ll » 17 Dec 2014, 19:20

OpenMW 0.34.0 Linux targz package release builds:

32 Bit
64 Bit

Post Reply