OpenMW 0.32.0

Anything related to PR, release planning and any other non-technical idea how to move the project forward should be discussed here.
User avatar
sandstranger
Posts: 438
Joined: 19 May 2014, 19:53
Location: Oblivion

Re: OpenMW 0.32.0

Post by sandstranger » 10 Sep 2014, 06:39

4
Last edited by sandstranger on 18 Jan 2018, 15:38, edited 2 times in total.

K0kt409P
Posts: 148
Joined: 06 Aug 2013, 09:14

Re: OpenMW 0.32.0

Post by K0kt409P » 10 Sep 2014, 09:22

raevol wrote:Testing testing. Can people post if they run these packages?
Played for a couple of hours last night with K1ll's 64-bit binary. No problems to report.

User avatar
Xelasarg
Posts: 27
Joined: 22 Jul 2014, 10:43

Re: OpenMW 0.32.0

Post by Xelasarg » 10 Sep 2014, 15:27

Damn, you fixed the "Enchant" bug. No more 100%-success-enchanting... ;)

Ace's RC3 on Win7 is making a good impression. Performance is pretty good by now, especially loading times seem to have decreased. Might only be my imagination, but still. RC3 runs stable, and the save game corruption I've been experiencing regularly with the different builds over the last couple of days seems to be gone, too. That was really nasty...

I found some Cliff Racers spinning in the air while walking round Red Mountain to Zergonipal, but overall everything's pretty fine. Hostile npc's use magic properly now to attack, something they didn't do before, at least to this extent.
“A reader lives a thousand lives before he dies. The man who never reads lives only once.”

User avatar
psi29a
Posts: 4631
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: OpenMW 0.32.0

Post by psi29a » 11 Sep 2014, 09:59

Just a heads up, I've had to add libav to our PPA (at least for Precise) so that travis can once again build:
https://github.com/OpenMW/openmw/pull/2 ... t-55226676

The reason for this is that we've been having issues with platforms that only support ffmpeg or libav. This wouldn't be so bad if it wasn't for the fact that libav decided to break away and do their own thing. This left us holding the bag. For those that don't know, these libs are what make music, sounds and video formats possible to playback in OpenMW.

Thanks to cc9cii, we've been able to bridge this and support both, at least for now. This no guarantee that we will support both in the future which doesn't look to good for OpenMW on Debian and Ubuntu until they finally bring ffmpeg back in to their distributions.

If this could be pulled in, we can do another round of RC(4) testing to validate this... mostly on the Debian/Ubuntu side.

User avatar
vv221
Posts: 55
Joined: 03 Oct 2012, 12:27
Location: France
Contact:

Re: OpenMW 0.32.0

Post by vv221 » 11 Sep 2014, 11:00

psi29a wrote:This no guarantee that we will support both in the future which doesn't look to good for OpenMW on Debian and Ubuntu until they finally bring ffmpeg back in to their distributions.
It should not be long before ffmpeg comes back into Debian repositories (maybe not for Jessie release though, but we could hope for a backport when it comes into Jessie+1):
https://bugs.debian.org/cgi-bin/bugrepo ... bug=729203

Hopefully Ubuntu will follow closely.

User avatar
Zini
Posts: 5536
Joined: 06 Aug 2011, 15:16

Re: OpenMW 0.32.0

Post by Zini » 11 Sep 2014, 13:21

Looks like everything is working. Tag has been created, Please start the release.

User avatar
psi29a
Posts: 4631
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: OpenMW 0.32.0

Post by psi29a » 11 Sep 2014, 14:24

Zini wrote:Looks like everything is working. Tag has been created, Please start the release.
No final RC cycle? ;)

Did you include the libav branch? Without it, there is no Debian release of 0.32

User avatar
Ace (SWE)
Posts: 829
Joined: 15 Aug 2011, 14:56

Re: OpenMW 0.32.0

Post by Ace (SWE) » 11 Sep 2014, 14:52

Windows release builds:
32-bit
64-bit

User avatar
Zini
Posts: 5536
Joined: 06 Aug 2011, 15:16

Re: OpenMW 0.32.0

Post by Zini » 11 Sep 2014, 16:41

psi29a wrote: Did you include the libav branch? Without it, there is no Debian release of 0.32
I wasn't aware of that. As far as I can tell this branch isn't ready. We are still having discussions going on about it.

Edit: Also, I can not get that branch to build in its current state (was working before).
marc:~/OpenMW/build$ make
-- Configuring OpenMW...
-- OpenMW version 0.31.0
CMake Error at CMakeLists.txt:156 (message):
FFmpeg component required, but not found!
Guess I am missing some packages somewhere.

User avatar
raevol
Posts: 3015
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: OpenMW 0.32.0

Post by raevol » 11 Sep 2014, 19:36

Readme is ready?

Post Reply