OpenMW 0.30.0

Anything related to PR, release planning and any other non-technical idea how to move the project forward should be discussed here.
densm27
Posts: 23
Joined: 02 Jun 2014, 18:34

Re: OpenMW 0.30.0

Post by densm27 » 02 Jun 2014, 18:53

Hello. I have noticed that the Broken dialog topics in russian Morrowind bug looks different in 0.30 Win64 version.
In 0.28 and 0.29, dialog topics just did not show up for me, but now they kinda work.. until first save/load. By step:
1) I run OpenMW, start a new game. After chargen, dialogs work as expected.
2) I save and load. No topics.
3) I start a new game. Again no topics.
4) I restart OpenMW and start a new game. Topics are back. If I load previously saved game, they disappear.

Hope this helps.

User avatar
scrawl
Posts: 2152
Joined: 18 Feb 2012, 11:51
Contact:

Re: OpenMW 0.30.0

Post by scrawl » 02 Jun 2014, 19:03

Thanks for the info. It would be better if you post this on the bugreport, or it will probably get lost.

User avatar
Berandas
Posts: 93
Joined: 28 Oct 2012, 11:23
Location: Prague, Czech Republic
Contact:

Re: OpenMW 0.30.0

Post by Berandas » 04 Jun 2014, 19:30

I continued my gameplay and found some more stuff that needs confirmation.

Custom made icon background texture for magical weapons and stuff isn't scaled properly on GUI. it's shrunk in top left corner of the icon. Also only icons with .dds format are used, .tga are not.

arkn_door00 and arkn_door01 meshes aren't moving when activated, although their collision boxes seems to be moving. (you can walk through the door)

Isn't there something wrong with cliffracers? I got the feeling, that they're unable to hit me.

I killed DB assassin when he was walking and his footsteps sound remained playing over and over, even when I re-entered the cell - this is probably unreproducable.

Dead bodies are changing their pose when re-entering the cell. It feels very disturbing.

Footsteps sound is played from Right/Left speaker instead of the center one, when strafing right/left.

Coin icon during the level up dialogue are often off the window background, scaling the background will probably solve this.

Would it be possible to add "qqq" console command for fast-quitting the game? :-)

And one more thing, is there some way to distort object shadows? It feels very odd, when during cloudy day or dark night all the object shadows are sharp.

User avatar
scrawl
Posts: 2152
Joined: 18 Feb 2012, 11:51
Contact:

Re: OpenMW 0.30.0

Post by scrawl » 04 Jun 2014, 19:43

Would it be possible to add "qqq" console command for fast-quitting the game? :-)
What's wrong with Alt+F4?
Custom made icon background texture for magical weapons and stuff isn't scaled properly on GUI. it's shrunk in top left corner of the icon. Also only icons with .dds format are used, .tga are not.
Please create two separate bug reports.
I killed DB assassin when he was walking and his footsteps sound remained playing over and over, even when I re-entered the cell - this is probably unreproducable.

Dead bodies are changing their pose when re-entering the cell. It feels very disturbing.

Footsteps sound is played from Right/Left speaker instead of the center one, when strafing right/left.
These 3 are already fixed in master.
arkn_door00 and arkn_door01 meshes aren't moving when activated, although their collision boxes seems to be moving. (you can walk through the door)

Isn't there something wrong with cliffracers? I got the feeling, that they're unable to hit me.
Already reported.
Coin icon during the level up dialogue are often off the window background, scaling the background will probably solve this.
Please create another bug report (attached screenshot would be good)

User avatar
Berandas
Posts: 93
Joined: 28 Oct 2012, 11:23
Location: Prague, Czech Republic
Contact:

Re: OpenMW 0.30.0

Post by Berandas » 04 Jun 2014, 21:05

scrawl wrote: What's wrong with Alt+F4?
Well, I guess everything is wrong with Alt+F4, since it didn't work in vanilla Morrowind and it doesn't work in OpenMW. Or at least for me. So is that another bug? :D

User avatar
scrawl
Posts: 2152
Joined: 18 Feb 2012, 11:51
Contact:

Re: OpenMW 0.30.0

Post by scrawl » 04 Jun 2014, 21:09

Yeah, another bug. Alt+F4 works for me on linux. You are on windows? Does it work in windowed mode and not in fullscreen? Or in neither? In windowed mode, does clicking on the "X" button next to the window title work?

User avatar
cc9cii
Posts: 449
Joined: 28 Mar 2013, 04:01

Re: OpenMW 0.30.0

Post by cc9cii » 04 Jun 2014, 21:20

Alt-F4 works for me, as does the 'x' at the top right hand corner. Alt-F4, however, is too awkward to use as a fast exit anyway (IMHO).

EDIT: Doesn't work in 0.30.0, so there must have been a recent change in the master
Last edited by cc9cii on 04 Jun 2014, 22:49, edited 1 time in total.

User avatar
Berandas
Posts: 93
Joined: 28 Oct 2012, 11:23
Location: Prague, Czech Republic
Contact:

Re: OpenMW 0.30.0

Post by Berandas » 04 Jun 2014, 22:49

scrawl wrote:Yeah, another bug. Alt+F4 works for me on linux. You are on windows? Does it work in windowed mode and not in fullscreen? Or in neither? In windowed mode, does clicking on the "X" button next to the window title work?
Yup, I'm using Win64 0.30.0 (367acd9676) version. It doesn't work either on fullscreen, or windowed mode. It can be closed by the close button in windowed mode.

I added all the bugs to the bug tracker, hope I did everythig right.

User avatar
scrawl
Posts: 2152
Joined: 18 Feb 2012, 11:51
Contact:

Re: OpenMW 0.30.0

Post by scrawl » 04 Jun 2014, 23:16

EDIT: Doesn't work in 0.30.0, so there must have been a recent change in the master
Hmm, not that I'm aware of.

@Berandas, can you try a nightly build and see if it is indeed fixed?

User avatar
cc9cii
Posts: 449
Joined: 28 Mar 2013, 04:01

Re: OpenMW 0.30.0

Post by cc9cii » 04 Jun 2014, 23:30

I'm using a fairly recent versions of SDL2, Ogre, Qt, etc - might be a factor.

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests