OpenMW 0.30.0

Anything related to PR, release planning and any other non-technical idea how to move the project forward should be discussed here.
User avatar
cc9cii
Posts: 436
Joined: 28 Mar 2013, 04:01

Re: OpenMW 0.30.0

Post by cc9cii » 29 May 2014, 02:04

Thanks for confirming, @raevol, is it too late to add another message to the release note?

User avatar
Greendogo
Posts: 1364
Joined: 26 Aug 2011, 02:04

Re: OpenMW 0.30.0

Post by Greendogo » 29 May 2014, 03:15

@Ace, the 0.30.0 Windows version still says it's a Development version instead of a Release.

User avatar
raevol
Posts: 2660
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: OpenMW 0.30.0

Post by raevol » 29 May 2014, 07:45

cc9cii wrote:Thanks for confirming, @raevol, is it too late to add another message to the release note?
Sort of. What exactly is the issue? CG shaders crash OpenMW on... Windows? Certain hardware?

User avatar
cc9cii
Posts: 436
Joined: 28 Mar 2013, 04:01

Re: OpenMW 0.30.0

Post by cc9cii » 29 May 2014, 08:45

I believe this is the situation: Windows + DirectX + CG Shaders = crash

Sload
Posts: 8
Joined: 08 May 2014, 04:08

Re: OpenMW 0.30.0

Post by Sload » 29 May 2014, 09:57

Hello,

I get a seg fault when I try to use OpenCS. Is this expected? I get the config file error described previously in this thread before the launcher window pops up, then when I try to go forward with any of the 3 options (new game or addon, modify a .esp) it crashes.

I am running Ubuntu 14.04 on a laptop with an AMD A6-3420M processor. I installed OpenMW 0.30.0 from the Launchpad repositories.

User avatar
Ace (SWE)
Posts: 775
Joined: 15 Aug 2011, 14:56

Re: OpenMW 0.30.0

Post by Ace (SWE) » 29 May 2014, 11:42

Greendogo wrote:@Ace, the 0.30.0 Windows version still says it's a Development version instead of a Release.
Are you sure you're not using the wrong version somehow? I downloaded both the 32 and 64-bit from the Github release and both of them report the version correctly

User avatar
Greendogo
Posts: 1364
Joined: 26 Aug 2011, 02:04

Re: OpenMW 0.30.0

Post by Greendogo » 29 May 2014, 16:01

Good question. I'll check when I get home here in a bit.

Edit:
I checked again and this is what is in the Launcher:
Image

I downloaded OpenMW-0.30.0-win32.exe from the OpenMW release page at Github here.
Last edited by Greendogo on 29 May 2014, 21:52, edited 1 time in total.

User avatar
Greendogo
Posts: 1364
Joined: 26 Aug 2011, 02:04

Re: OpenMW 0.30.0

Post by Greendogo » 29 May 2014, 20:17

In an unrelated matter, I thought we were having Object Shaders be disabled by default after install?

Edit:
And can we silence some of the console spam? This isn't very helpful:
Spoiler: Show
Edit 2: It looks like the console spam I posted about was because of a problem with DirectX. Fixed it.
Last edited by Greendogo on 31 May 2014, 06:50, edited 1 time in total.

User avatar
Ace (SWE)
Posts: 775
Joined: 15 Aug 2011, 14:56

Re: OpenMW 0.30.0

Post by Ace (SWE) » 30 May 2014, 15:09

Strange, the commit hash is correct but it somehow decided not to find the release tag?

I'm not going to bother trying to rebuild the release package since it's just a cosmetic issue, but it's still strange though.

User avatar
Greendogo
Posts: 1364
Joined: 26 Aug 2011, 02:04

Re: OpenMW 0.30.0

Post by Greendogo » 31 May 2014, 06:50

Yeah, don't worry about it. It's a minor thing.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests