OpenMW 0.29.0

Anything related to PR, release planning and any other non-technical idea how to move the project forward should be discussed here.
Tolchock
Posts: 49
Joined: 13 Nov 2012, 00:28

Re: OpenMW 0.29.0

Post by Tolchock » 25 Feb 2014, 02:44

I can confirm that saving works in Ace's 64bit build, at least.

corristo
Posts: 493
Joined: 12 Aug 2011, 08:29

Re: OpenMW 0.29.0

Post by corristo » 25 Feb 2014, 05:42


User avatar
psi29a
Posts: 4735
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: OpenMW 0.29.0

Post by psi29a » 25 Feb 2014, 13:27


User avatar
Lazaroth
Posts: 220
Joined: 30 May 2012, 05:04

Re: OpenMW 0.29.0

Post by Lazaroth » 25 Feb 2014, 17:02

Saving and loading works here as well. (win 64-bit)

User avatar
raevol
Posts: 3054
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: OpenMW 0.29.0

Post by raevol » 25 Feb 2014, 18:04

All, just a note, google code's file hosting ended after our last release, so we need a new place to host the downloads? Do we just want to use downloads.openmw.org?

Also, is the readme ready for me Zini?

User avatar
Amenophis
Posts: 271
Joined: 30 Oct 2011, 04:34
Location: Fortaleza - Ceará - Brasil

Re: OpenMW 0.29.0

Post by Amenophis » 25 Feb 2014, 18:26

The save and load are working most perfectly. But I can´t overwrite a preexistent savegame. New bug? (Win 7, 64 bits).
My fixes and tweaks on vanilla and modded quests for Morrowind.
http://www.nexusmods.com/morrowind/mods/43107/?

User avatar
cc9cii
Posts: 487
Joined: 28 Mar 2013, 04:01

Re: OpenMW 0.29.0

Post by cc9cii » 25 Feb 2014, 18:43

Finally have a debug 32bit built. I may have been premature suspecting Ogre, although the crash is happening inside it.

It dies during bulkPixelConversion()

Code: Select all

		PixelBox convBox(pImgData->width, pImgData->height, 1, requiredFormat);
		if (requiredFormat != pImgData->format)
		{
			conversionRequired = true;
			// Allocate memory
			convBox.data = OGRE_ALLOC_T(uchar, convBox.getConsecutiveSize(), MEMCATEGORY_GENERAL);
			// perform conversion and reassign source
			PixelBox newSrc(pImgData->width, pImgData->height, 1, pImgData->format, input->getPtr());
			PixelUtil::bulkPixelConversion(newSrc, convBox);
			srcData = static_cast<unsigned char*>(convBox.data);
		}
initiated from screenshot.encode(), doesn't matter what format. I've tried "jpg", "bmp" and "png".

Code: Select all

    Ogre::DataStreamPtr encoded = screenshot.encode("png");
It might be that our image may not be fully constructed. Ogre seems to want a name? But then why does x64 work?
Last edited by cc9cii on 25 Feb 2014, 18:57, edited 1 time in total.

User avatar
WeirdSexy
Posts: 611
Joined: 15 Sep 2011, 18:50
Location: USA

Re: OpenMW 0.29.0

Post by WeirdSexy » 25 Feb 2014, 18:55

Reporting in.

I'm very sorry but can make no guarantee that I will be able to make a release commentary until the end of next week. I'll sure as hell try.

User avatar
cc9cii
Posts: 487
Joined: 28 Mar 2013, 04:01

Re: OpenMW 0.29.0

Post by cc9cii » 25 Feb 2014, 19:10

I've got both x64 and x32 on debugger. The 32bit one doesn't have any data in the buffer by the time encode() is called.

The 32bit one's world.screenshot() call does not produce a screenshot. Need to step through that one.

User avatar
cc9cii
Posts: 487
Joined: 28 Mar 2013, 04:01

Re: OpenMW 0.29.0

Post by cc9cii » 25 Feb 2014, 19:22

WeirdSexy wrote:Reporting in.

I'm very sorry but can make no guarantee that I will be able to make a release commentary until the end of next week. I'll sure as hell try.
At this rate of progress it may take longer than that to get 0.29 out ;)

Post Reply