OpenMW Nightly builds

Anything related to PR, release planning and any other non-technical idea how to move the project forward should be discussed here.
TheOneWhoWatches
Posts: 57
Joined: 08 Apr 2014, 07:06
Location: Russia/Siberia

Re: OpenMW Nightly builds

Post by TheOneWhoWatches » 26 Sep 2019, 14:52

psychotrip wrote:
23 Sep 2019, 19:34
silentthief wrote:
23 Sep 2019, 18:46
psychotrip wrote:
23 Sep 2019, 03:27
Woahhh! It's been a while since I installed a nightly, but for some reason when I enter the game the framerate drops to around 1fps and I can somehow see certain objects through walls? It's very disorienting and unplayable. Did I do something wrong?
Can you give a little more info? Which nightly and what OS are you on. Also, any mods active, and did you have this issue on any other nightlies or installs?
lysol wrote:
13 Aug 2019, 08:56
How about a mod where as soon as you have a blind effect going, the game starts playing this?
Also Lysol, that is hilarious :lol: :lol: :lol:

ST the amused
Sure thing! I believe I'm using the latest one that came out yesterday. I just clicked the link tot he 64 bit download on the first page. I'm using Windows 7 and I have...a lot of mods. I've never had this issue on other nightlies though, nor is this an issue in my regular OpenMW install (which is the latest official version).

Edit: Okay I've confirmed that even without any mods the problem persists. No clue what could be causing this now. I have a 64 bit system and I'm using the 64 bit version so I have no clue what else could be causing such random weirdness.

Edit 2: Okay I tried the latest Nightly (9/26) and I have the exact same issue, even with no mods. This is so bizarre. I must be doing something wrong but I can't figure out what.
I had something similar after upgrade to latest nightly.
In my case it was caused by comments (#) in openmw config file (the one with [camera] section and so on)
After moving them to new lines everything got back to normal.
Game didn't like them (#) being on the same line as options. It happened after one of the summer nightlies, can't remember when, but I probably can check that if needed.

psychotrip
Posts: 19
Joined: 21 Aug 2018, 15:18

Re: OpenMW Nightly builds

Post by psychotrip » 27 Sep 2019, 00:05

TheOneWhoWatches wrote:
26 Sep 2019, 14:52
psychotrip wrote:
23 Sep 2019, 19:34
silentthief wrote:
23 Sep 2019, 18:46
psychotrip wrote:
23 Sep 2019, 03:27
Woahhh! It's been a while since I installed a nightly, but for some reason when I enter the game the framerate drops to around 1fps and I can somehow see certain objects through walls? It's very disorienting and unplayable. Did I do something wrong?
Can you give a little more info? Which nightly and what OS are you on. Also, any mods active, and did you have this issue on any other nightlies or installs?
lysol wrote:
13 Aug 2019, 08:56
How about a mod where as soon as you have a blind effect going, the game starts playing this?
Also Lysol, that is hilarious :lol: :lol: :lol:

ST the amused
Sure thing! I believe I'm using the latest one that came out yesterday. I just clicked the link tot he 64 bit download on the first page. I'm using Windows 7 and I have...a lot of mods. I've never had this issue on other nightlies though, nor is this an issue in my regular OpenMW install (which is the latest official version).

Edit: Okay I've confirmed that even without any mods the problem persists. No clue what could be causing this now. I have a 64 bit system and I'm using the 64 bit version so I have no clue what else could be causing such random weirdness.

Edit 2: Okay I tried the latest Nightly (9/26) and I have the exact same issue, even with no mods. This is so bizarre. I must be doing something wrong but I can't figure out what.
I had something similar after upgrade to latest nightly.
In my case it was caused by comments (#) in openmw config file (the one with [camera] section and so on)
After moving them to new lines everything got back to normal.
Game didn't like them (#) being on the same line as options. It happened after one of the summer nightlies, can't remember when, but I probably can check that if needed.
Thanks for the reply! I tried doing what you suggested and spaced out the (#) under [camera] but I still have the same problem! Any other ideas? Would showing you guys my settings.cfg file help?

Edit: actually I'm not sure I actually did what you suggested since I'm not sure I understand it. Could you elaborate a bit further? Are you saying (#) shouldn't be on the same lines as the options themselves? So instead of reading like,

# small feature culling pixel size = 8.0

It should look like,

#
small feature culling pixel size = 8.0

Is that what you mean? Or are you saying that instead of saying,

# Cull objects that occupy less than 'small feature culling pixel size' on the screen.
small feature culling = true
# small feature culling pixel size = 8.0

It should look like,

# Cull objects that occupy less than 'small feature culling pixel size' on the screen.
small feature culling = true

# small feature culling pixel size = 8.0

I am so confused...

TheOneWhoWatches
Posts: 57
Joined: 08 Apr 2014, 07:06
Location: Russia/Siberia

Re: OpenMW Nightly builds

Post by TheOneWhoWatches » 27 Sep 2019, 04:29

Ah, sorry, I was too distracted at the moment.
Let me clarify what I wanted to say:
I had settings.cfg with lines like this (I don't have old copy so I can't say for sure what actual lines looked like)

Code: Select all

viewing distance = 6666666 # Determines how much land is rendered. Add another 6 or 66 to it.
and after updating openmw to one of the summer nightlies I got this (screenshots attached)

I renamed settings.cfg and everything got back to normal.
So I started fiddling with it and after moving comments to new lines like this:

Code: Select all

# Determines how much land is rendered. Add another 6 or 66 to it.
viewing distance = 6666666
everything returned to normal

Edit: yep, just tried this line and got that result with white models (screenshot).
Seems like there were other lines involved since the result was different.
Anyway, renaming settings.cfg might do the trick if you see something similar.
Attachments
screenshot000.jpg
screenshot000.jpg (62.05 KiB) Viewed 865 times
screenshot002.jpg
screenshot002.jpg (96.22 KiB) Viewed 865 times
screenshot001.jpg
screenshot001.jpg (172.07 KiB) Viewed 865 times
screenshot000.jpg
screenshot000.jpg (144.18 KiB) Viewed 865 times

psychotrip
Posts: 19
Joined: 21 Aug 2018, 15:18

Re: OpenMW Nightly builds

Post by psychotrip » 27 Sep 2019, 05:04

TheOneWhoWatches wrote:
27 Sep 2019, 04:29
Ah, sorry, I was too distracted at the moment.
Let me clarify what I wanted to say:
I had settings.cfg with lines like this (I don't have old copy so I can't say for sure what actual lines looked like)

Code: Select all

viewing distance = 6666666 # Determines how much land is rendered. Add another 6 or 66 to it.
and after updating openmw to one of the summer nightlies I got this (screenshots attached)

I renamed settings.cfg and everything got back to normal.
So I started fiddling with it and after moving comments to new lines like this:

Code: Select all

# Determines how much land is rendered. Add another 6 or 66 to it.
viewing distance = 6666666
everything returned to normal

Edit: yep, just tried this line and got that result with white models (screenshot).
Seems like there were other lines involved since the result was different.
Anyway, renaming settings.cfg might do the trick if you see something similar.
This is exactly my problem! It looks just like this! I'll double check and see if settings.cfg has the (#) problem you mentioned (I understand it now). If that doesn't work, what should I change the name of settings.cfg to? Does it matter? Thank you so much! I hope this works...

Edit: Nope. Doesn't work. I don't see the problem you had in settings.cfg and changing the name doesn't fix anything (I renamed it settings2.cfg).
Last edited by psychotrip on 27 Sep 2019, 05:07, edited 1 time in total.

TheOneWhoWatches
Posts: 57
Joined: 08 Apr 2014, 07:06
Location: Russia/Siberia

Re: OpenMW Nightly builds

Post by TheOneWhoWatches » 27 Sep 2019, 05:06

psychotrip wrote:
27 Sep 2019, 05:04
TheOneWhoWatches wrote:
27 Sep 2019, 04:29
Ah, sorry, I was too distracted at the moment.
Let me clarify what I wanted to say:
I had settings.cfg with lines like this (I don't have old copy so I can't say for sure what actual lines looked like)

Code: Select all

viewing distance = 6666666 # Determines how much land is rendered. Add another 6 or 66 to it.
and after updating openmw to one of the summer nightlies I got this (screenshots attached)

I renamed settings.cfg and everything got back to normal.
So I started fiddling with it and after moving comments to new lines like this:

Code: Select all

# Determines how much land is rendered. Add another 6 or 66 to it.
viewing distance = 6666666
everything returned to normal

Edit: yep, just tried this line and got that result with white models (screenshot).
Seems like there were other lines involved since the result was different.
Anyway, renaming settings.cfg might do the trick if you see something similar.
This is exactly my problem! It looks just like this! I'll double check and see if settings.cfg has the (#) problem you mentioned (I understand it now). If that doesn't work, what should I change the name of settings.cfg to? Does it matter? Thank you so much! I hope this works...
I said rename as a means to avoid deleting it in case you'll want to reuse some of the options, so any other name will do.
Hope you'll solve your problem =)

psychotrip
Posts: 19
Joined: 21 Aug 2018, 15:18

Re: OpenMW Nightly builds

Post by psychotrip » 27 Sep 2019, 05:08

TheOneWhoWatches wrote:
27 Sep 2019, 05:06
psychotrip wrote:
27 Sep 2019, 05:04
TheOneWhoWatches wrote:
27 Sep 2019, 04:29
Ah, sorry, I was too distracted at the moment.
Let me clarify what I wanted to say:
I had settings.cfg with lines like this (I don't have old copy so I can't say for sure what actual lines looked like)

Code: Select all

viewing distance = 6666666 # Determines how much land is rendered. Add another 6 or 66 to it.
and after updating openmw to one of the summer nightlies I got this (screenshots attached)

I renamed settings.cfg and everything got back to normal.
So I started fiddling with it and after moving comments to new lines like this:

Code: Select all

# Determines how much land is rendered. Add another 6 or 66 to it.
viewing distance = 6666666
everything returned to normal

Edit: yep, just tried this line and got that result with white models (screenshot).
Seems like there were other lines involved since the result was different.
Anyway, renaming settings.cfg might do the trick if you see something similar.
This is exactly my problem! It looks just like this! I'll double check and see if settings.cfg has the (#) problem you mentioned (I understand it now). If that doesn't work, what should I change the name of settings.cfg to? Does it matter? Thank you so much! I hope this works...
I said rename as a means to avoid deleting it in case you'll want to reuse some of the options, so any other name will do.
Hope you'll solve your problem =)
Hmmm well, either way, doesn't seem to work. I don't see the problem you had in settings.cfg and changing the name doesn't fix anything (I renamed it settings2.cfg). Sorry, I really don't get how most of this stuff works or even what this problem is in the first place. So sorry if I'm having trouble following your instructions haha.

Edit: also wait...if I changed the name of settings.cfg wouldn't that make it so the settings wouldn't actually work? That would mean that the issue can't be my settings right? Since even when I changed the name of the settings.cfg, I still got the jacked up visuals and low framerate. So, if it's not the settings or mods what could it be?

TheOneWhoWatches
Posts: 57
Joined: 08 Apr 2014, 07:06
Location: Russia/Siberia

Re: OpenMW Nightly builds

Post by TheOneWhoWatches » 27 Sep 2019, 05:13

psychotrip wrote:
27 Sep 2019, 05:08
TheOneWhoWatches wrote:
27 Sep 2019, 05:06
psychotrip wrote:
27 Sep 2019, 05:04
TheOneWhoWatches wrote:
27 Sep 2019, 04:29
Ah, sorry, I was too distracted at the moment.
Let me clarify what I wanted to say:
I had settings.cfg with lines like this (I don't have old copy so I can't say for sure what actual lines looked like)

Code: Select all

viewing distance = 6666666 # Determines how much land is rendered. Add another 6 or 66 to it.
and after updating openmw to one of the summer nightlies I got this (screenshots attached)

I renamed settings.cfg and everything got back to normal.
So I started fiddling with it and after moving comments to new lines like this:

Code: Select all

# Determines how much land is rendered. Add another 6 or 66 to it.
viewing distance = 6666666
everything returned to normal

Edit: yep, just tried this line and got that result with white models (screenshot).
Seems like there were other lines involved since the result was different.
Anyway, renaming settings.cfg might do the trick if you see something similar.
This is exactly my problem! It looks just like this! I'll double check and see if settings.cfg has the (#) problem you mentioned (I understand it now). If that doesn't work, what should I change the name of settings.cfg to? Does it matter? Thank you so much! I hope this works...
I said rename as a means to avoid deleting it in case you'll want to reuse some of the options, so any other name will do.
Hope you'll solve your problem =)
Hmmm well, either way, doesn't seem to work. I don't see the problem you had in settings.cfg and changing the name doesn't fix anything (I renamed it settings2.cfg). Sorry, I really don't get how most of this stuff works or even what this problem is in the first place. So sorry if I'm having trouble following your instructions haha.
Try to rename/delete openmw config folder (my documents\my games\openmw) and configure it anew?
Just a guess...
psychotrip wrote:
27 Sep 2019, 05:08
Edit: also wait...if I changed the name of settings.cfg wouldn't that make it so the settings wouldn't actually work? That would mean that the issue can't be my settings right? Since even when I changed the name of the settings.cfg, I still got the jacked up visuals and low framerate. So, if it's not the settings or mods what could it be?
Yes, seems like it... Strange, but that was the only thing that was causing such a problem in my case...
There's also two settings-default.cfg (in config foldeer and openmw install folder), but I doubt you changed it...

psychotrip
Posts: 19
Joined: 21 Aug 2018, 15:18

Re: OpenMW Nightly builds

Post by psychotrip » 27 Sep 2019, 05:27

TheOneWhoWatches wrote:
27 Sep 2019, 05:13
psychotrip wrote:
27 Sep 2019, 05:08
TheOneWhoWatches wrote:
27 Sep 2019, 05:06
psychotrip wrote:
27 Sep 2019, 05:04
TheOneWhoWatches wrote:
27 Sep 2019, 04:29
Ah, sorry, I was too distracted at the moment.
Let me clarify what I wanted to say:
I had settings.cfg with lines like this (I don't have old copy so I can't say for sure what actual lines looked like)

Code: Select all

viewing distance = 6666666 # Determines how much land is rendered. Add another 6 or 66 to it.
and after updating openmw to one of the summer nightlies I got this (screenshots attached)

I renamed settings.cfg and everything got back to normal.
So I started fiddling with it and after moving comments to new lines like this:

Code: Select all

# Determines how much land is rendered. Add another 6 or 66 to it.
viewing distance = 6666666
everything returned to normal

Edit: yep, just tried this line and got that result with white models (screenshot).
Seems like there were other lines involved since the result was different.
Anyway, renaming settings.cfg might do the trick if you see something similar.
This is exactly my problem! It looks just like this! I'll double check and see if settings.cfg has the (#) problem you mentioned (I understand it now). If that doesn't work, what should I change the name of settings.cfg to? Does it matter? Thank you so much! I hope this works...
I said rename as a means to avoid deleting it in case you'll want to reuse some of the options, so any other name will do.
Hope you'll solve your problem =)
Hmmm well, either way, doesn't seem to work. I don't see the problem you had in settings.cfg and changing the name doesn't fix anything (I renamed it settings2.cfg). Sorry, I really don't get how most of this stuff works or even what this problem is in the first place. So sorry if I'm having trouble following your instructions haha.
Try to rename/delete openmw config folder (my documents\my games\openmw) and configure it anew?
Just a guess...
psychotrip wrote:
27 Sep 2019, 05:08
Edit: also wait...if I changed the name of settings.cfg wouldn't that make it so the settings wouldn't actually work? That would mean that the issue can't be my settings right? Since even when I changed the name of the settings.cfg, I still got the jacked up visuals and low framerate. So, if it's not the settings or mods what could it be?
Yes, seems like it... Strange, but that was the only thing that was causing such a problem in my case...
There's also two settings-default.cfg (in config foldeer and openmw install folder), but I doubt you changed it...
Yeah...I have no idea what's happening now. Am I just stuck like this? I really hope the next official openmw doesn't do this for me, otherwise, I just can't use it anymore.

Edit: Maybe it's installed in the wrong place? Maybe it's named wrong? I'm just shooting in the dark now. Here's where I put the nightly install:

D:\Program Files\OpenMW 0.46.0\openmw-launcher.exe

TheOneWhoWatches
Posts: 57
Joined: 08 Apr 2014, 07:06
Location: Russia/Siberia

Re: OpenMW Nightly builds

Post by TheOneWhoWatches » 27 Sep 2019, 05:32

Everything looks fine.
Other than renaming/deleting openmw config folder in "my documents\my games" (to start from clean slate), I have no idea.

psychotrip
Posts: 19
Joined: 21 Aug 2018, 15:18

Re: OpenMW Nightly builds

Post by psychotrip » 27 Sep 2019, 05:36

TheOneWhoWatches wrote:
27 Sep 2019, 05:32
Everything looks fine.
Other than renaming/deleting openmw config folder in "my documents\my games" (to start from clean slate), I have no idea.
You mean openmw.cfg? Once I delete it, how do I get new one?

Edit: Okay I took the plunge and did it without understanding what I was doing. It asked me to run the installation wizard again. I did that. I opened up the OpenMW nightly. The problem is still exactly the same.
Last edited by psychotrip on 27 Sep 2019, 05:44, edited 1 time in total.

Post Reply