Page 2 of 44

Re: OpenMW Nightly builds

Posted: 29 Apr 2014, 05:43
by Lazaroth
The build is still not updating. From what I can see in the log, it says "Build FAILED.", and another issue I see is that in the list, it points towards zinnschlag instead of the new openmw github.

Re: OpenMW Nightly builds

Posted: 29 Apr 2014, 10:35
by Ace (SWE)
Oh right, haven't updated the list page. Thanks for noticing, fixed now.

And yeah, the builds have been broken a few days. Posted about it on IRC but haven't had the time to fix the problems myself.

Re: OpenMW Nightly builds

Posted: 24 May 2014, 21:02
by cc9cii
@ACE: Would you mind trying an old but newer version of FFmpeg in your builds, perhaps starting with your nightlies or targeting 0.31 please? See forum message viewtopic.php?f=20&t=2076&p=24625#p24625

I no longer have video related crashes using that version of FFmpeg but I would like more feedback from a wider group of windows users, x64 especially. Thanks in advance :-)

A summary of my findings on which versions work:
Spoiler: Show

Re: OpenMW Nightly builds

Posted: 06 Jun 2014, 02:47
by cc9cii
Ace, this is regarding the Alt-F4 issue.

The SDL2.dll packaged with OpenMW 0.30.0 appears to have been built on 10/02/2014:
Spoiler: Show
I'm not 100% sure, but looks like there was a fix for an Alt-F4 a few days after:
Spoiler: Show
I believe using a later version (2.0.2 or 2.0.3) will resolve the problem. Would you mind trying a newer version of SDL2 with your builds please?

Re: OpenMW Nightly builds

Posted: 08 Jun 2014, 17:37
by Ace (SWE)
Right, shouldn't be much trouble to update the build. Not going to be able to do it now though, since I'm at my parents. Birthday and all that.

Re: OpenMW Nightly builds

Posted: 13 Jun 2014, 00:57
by Greendogo
Hey Ace, the builds seemed to have stopped about ten days ago

Re: OpenMW Nightly builds

Posted: 13 Jun 2014, 16:39
by Ace (SWE)
Yeah, I see that. The scheduled task reports a last run as of 2014-06-13 04:00, but the timestamp on the build data is 2014-06-02 04:10. I'm going to dig through this a while and see what could've happened since the schedule seems to run without actually launching the build scripts.

Either way, next nightly will be up as usual, and I promise you that.

Re: OpenMW Nightly builds

Posted: 14 Jun 2014, 00:45
by Greendogo
Ace (SWE) wrote:Yeah, I see that. The scheduled task reports a last run as of 2014-06-13 04:00, but the timestamp on the build data is 2014-06-02 04:10. I'm going to dig through this a while and see what could've happened since the schedule seems to run without actually launching the build scripts.

Either way, next nightly will be up as usual, and I promise you that.
Awesome, thank you sir! :D

Re: OpenMW Nightly builds

Posted: 15 Jun 2014, 23:24
by scrawl
Ace, are you using an SVN version of MyGUI by any chance? That would explain #1277

Edit: either way, fixed. Both SVN and 3.2 should be just fine now.

Re: OpenMW Nightly builds

Posted: 16 Jun 2014, 23:11
by Ace (SWE)
scrawl wrote:Ace, are you using an SVN version of MyGUI by any chance? That would explain #1277

Edit: either way, fixed. Both SVN and 3.2 should be just fine now.
Oh right, yeah I'm using an SVN version of MyGUI.
And I just realized I forgot to upgrade SDL, got sidetracked with other work that needed to be done.

I'll try to get on it tomorrow or the day after.