[solved] Anyone know how to disable these black textures?

General discussion regarding the OpenMW project.
For technical support, please use the Support subforum.
Post Reply
mnoblemusic
Posts: 4
Joined: 18 Aug 2018, 21:22

[solved] Anyone know how to disable these black textures?

Post by mnoblemusic » 18 Aug 2018, 21:30

Original Post:
Spoiler: Show
Hey guys! Been playing OpenMW for a while, because this is probably one of the best things on the internet obviously haha.

So, I updated to the new version 44, and I guess I forgot to save some of my settings. When you look up, in any environment, these black textures show up on surfaces. I had this disabled on the previous version, but I completely forgot how I did it... I'm just curious if anyone here knows how to turn this off?
I don't remember what file I used, or if it was a shader or shadow setting, but I had this turned off somehow. (P.s. I'm on Mac, if that matters at all)

Thanks guys!
Spoiler: Show
Spoiler: Show
settings.cfg
Spoiler: Show
[/spoiler]

If you're experiencing this same problem, find "settings-default.cfg". Open it up, search for "clamp lighting = true" and change the value to "false". That fixes it, in case anyone runs into this same thing!

Thanks to everyone who responded, appreciate you guys.
Last edited by mnoblemusic on 19 Aug 2018, 06:55, edited 2 times in total.

User avatar
AnyOldName3
Posts: 1121
Joined: 26 Nov 2015, 03:25

Re: Anyone know how to disable these black textures?

Post by AnyOldName3 » 19 Aug 2018, 00:20

That's definitely not supposed to happen, and I'm not aware of any setting that would cause that kind of issue. I suspect it's actually a bug.
AnyOldName3, Master of Shadows

Equinox
Posts: 15
Joined: 31 Jul 2018, 20:13

Re: Anyone know how to disable these black textures?

Post by Equinox » 19 Aug 2018, 00:27

mnoblemusic wrote:
18 Aug 2018, 21:30
Hey guys! Been playing OpenMW for a while, because this is probably one of the best things on the internet obviously haha.

So, I updated to the new version 44, and I guess I forgot to save some of my settings. When you look up, in any environment, these black textures show up on surfaces. I had this disabled on the previous version, but I completely forgot how I did it... I'm just curious if anyone here knows how to turn this off?
I don't remember what file I used, or if it was a shader or shadow setting, but I had this turned off somehow. (P.s. I'm on Mac, if that matters at all)

Thanks guys!
Spoiler: Show
Spoiler: Show
If you installed a new openmw version, i dont think your settings in would be overwritten. New version will still use the old settings found in your game folder, in ocmputer->documents.

Try disabling shader in your settings.cfg.

EDIT: sorry, didnt notice you said youre on MAC

mnoblemusic
Posts: 4
Joined: 18 Aug 2018, 21:22

Re: Anyone know how to disable these black textures?

Post by mnoblemusic » 19 Aug 2018, 00:28

Definitely a bug for sure, but there's a setting somewhere that disables it, because I did it on the last build. I should have made a note of which one haha.

mnoblemusic
Posts: 4
Joined: 18 Aug 2018, 21:22

Re: Anyone know how to disable these black textures?

Post by mnoblemusic » 19 Aug 2018, 00:32

Equinox wrote:
19 Aug 2018, 00:27
mnoblemusic wrote:
18 Aug 2018, 21:30
Hey guys! Been playing OpenMW for a while, because this is probably one of the best things on the internet obviously haha.

So, I updated to the new version 44, and I guess I forgot to save some of my settings. When you look up, in any environment, these black textures show up on surfaces. I had this disabled on the previous version, but I completely forgot how I did it... I'm just curious if anyone here knows how to turn this off?
I don't remember what file I used, or if it was a shader or shadow setting, but I had this turned off somehow. (P.s. I'm on Mac, if that matters at all)

Thanks guys!
Spoiler: Show
Spoiler: Show
If you installed a new openmw version, i dont think your settings in would be overwritten. New version will still use the old settings found in your game folder, in ocmputer->documents.

Try disabling shader in your settings.cfg.

EDIT: sorry, didnt notice you said youre on MAC
Thanks! That makes sense, didn't really think about that. I've disabled every shader I can think of, it's still there. Unless I'm missing one. I'll upload my settings here in a sec.

User avatar
AnyOldName3
Posts: 1121
Joined: 26 Nov 2015, 03:25

Re: Anyone know how to disable these black textures?

Post by AnyOldName3 » 19 Aug 2018, 01:07

Where's the first post gone? At least at my end, it's showing my reply as the original post.
AnyOldName3, Master of Shadows

mnoblemusic
Posts: 4
Joined: 18 Aug 2018, 21:22

Re: Anyone know how to disable these black textures?

Post by mnoblemusic » 19 Aug 2018, 01:09

AnyOldName3 wrote:
19 Aug 2018, 01:07
Where's the first post gone? At least at my end, it's showing my reply as the original post.
I'm not sure, I edited it with my settings and the post disappeared :shock: Here it is again though just in case
Spoiler: Show

User avatar
psi29a
Posts: 4255
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: [solved] Anyone know how to disable these black textures?

Post by psi29a » 19 Aug 2018, 08:41

The first post was 'flagged' for approval, until it is approved, it won't show. Anyone that is a mod should be able to approve it.

Calibration
Posts: 10
Joined: 20 Dec 2016, 18:38

Re: [solved] Anyone know how to disable these black textures?

Post by Calibration » 20 Aug 2018, 17:46

Excuse my confusion. This seems to be the same issue I had here

viewtopic.php?f=8&t=4019

and is still with me (currently on 0.44.0). Look up a bit and the ground goes black.

First post in this thread seems to have been edited to suggest that if you change "clamp lighting = true" to "clamp lighting = false" it will fix it and the problem is solved. Earlier dated posts from the Devs suggest it is a bug.

I have put "clamp lighting = false" along with "force shaders = true" into settings.cfg (I assume this is correct) and it makes no difference at all as per the suggestion it is some sort of Mac bug.

No biggie. Doesn't spoil my enjoyment of the game.

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests