found a huge issue in the new release (0.44.0 release)

General discussion regarding the OpenMW project.
For technical support, please use the Support subforum.
User avatar
kuyondo
Posts: 221
Joined: 29 Mar 2016, 17:45

Re: found a huge issue in the new release (0.44.0 release)

Post by kuyondo » 29 Jul 2018, 12:14

To update the weather quickly, after using changeweather, wait 1 hour(using the rest menu).

You can press "T" to rest, but if the area youre currently in doesnt allow resting, it will change to wait instead.

User avatar
rstevenson1976
Posts: 56
Joined: 14 Apr 2015, 03:55
Location: North Carolina, USA

Re: found a huge issue in the new release (0.44.0 release)

Post by rstevenson1976 » 29 Jul 2018, 22:54

I uninstalled the ppa version and just tried the flatpak, the ram usage is 60%, still higher than I'm comfortable with, but it's not hard-locking my computer any more...


long story short, it's not just weather after all, in the flatpak I waited out a ash storm with no issue, it's not just distant terrain or view distance or frame cell loading higher than a single cell, cause in the ppa version I was inside an interior cell (Ald-ruhn, mages guild), and the ram usage was still over 75%, it also hard-locked my computer just trying to get from the bed to the exit. I dunno why this is affecting literally no one else and can't be replicated by anyone here. doesn't make it so it didn't happen to me, doesn't make it any less of a problem, doesn't mean it can be dismissed and ignored.

User avatar
raevol
Posts: 2802
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: found a huge issue in the new release (0.44.0 release)

Post by raevol » 29 Jul 2018, 23:20

rstevenson1976 wrote:
29 Jul 2018, 22:54
I dunno why this is affecting literally no one else and can't be replicated by anyone here. doesn't make it so it didn't happen to me, doesn't make it any less of a problem, doesn't mean it can be dismissed and ignored.
If we can't replicate it, we can't fix it. Simple as that. Everyone believes you that it is an issue, but if you are the only one who has it (which it could be happening to other people and we just don't know yet! hopefully someone else can replicate it and we can narrow it down!) then we have to assume it's an issue with your particular setup/configuration.

Running a completely clean, unmodded install on a fresh install of a known, standard OS (like vanilla Ubuntu 18.04) would help, if you wouldn't mind putting in the effort? If you can replicate it under those conditions, we know it's truly the "fault" of OpenMW, but if you can't and no one else can replicate it, we have to assume it's your OS or drivers or configuration etc...

User avatar
rstevenson1976
Posts: 56
Joined: 14 Apr 2015, 03:55
Location: North Carolina, USA

Re: found a huge issue in the new release (0.44.0 release)

Post by rstevenson1976 » 30 Jul 2018, 03:43

I did a workaround for what can not be accused of being efficient memory management, I created a nearly 38GB swap partition, the game works just fine now




::edit::
Mint is a mainstream os, the very mods I'm using now were the very mods I've been using in 0.43.0 in Mint 19, Miint 18.3, and ubuntu 16.04. zero ill-effects before, so don't be so quick to blame them now, don't be so quick to blame my drivers (lawl, do you even use linux at all?), and certainly don't be so quick to blame my os. I linked in an earlier post just how much ram openmw 0.44.0 uses: indoors, outdoors, rain, sunshine, day, night.

User avatar
raevol
Posts: 2802
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: found a huge issue in the new release (0.44.0 release)

Post by raevol » 30 Jul 2018, 04:49

Glad you got it fixed! :)

User avatar
AnyOldName3
Posts: 1192
Joined: 26 Nov 2015, 03:25

Re: found a huge issue in the new release (0.44.0 release)

Post by AnyOldName3 » 30 Jul 2018, 23:26

Mint is a mainstream os
My experience with Mint has always been that it changes very little about Ubuntu, but what it does change, it usually changes in batshit crazy ways which break things. It's not impossible that they've done something that makes the graphics driver eat lots of RAM when asked to do something which OpenMW tries to do, regardless of whether or not OpenMW is supposed to ask it to do that thing.
AnyOldName3, Master of Shadows

User avatar
rstevenson1976
Posts: 56
Joined: 14 Apr 2015, 03:55
Location: North Carolina, USA

Re: found a huge issue in the new release (0.44.0 release)

Post by rstevenson1976 » 31 Jul 2018, 00:53

AnyOldName3 wrote:
30 Jul 2018, 23:26
Mint is a mainstream os
My experience with Mint has always been that it changes very little about Ubuntu, but what it does change, it usually changes in batshit crazy ways which break things. It's not impossible that they've done something that makes the graphics driver eat lots of RAM when asked to do something which OpenMW tries to do, regardless of whether or not OpenMW is supposed to ask it to do that thing.
name me one app besides this one that has ever happened, I'll wait

User avatar
AnyOldName3
Posts: 1192
Joined: 26 Nov 2015, 03:25

Re: found a huge issue in the new release (0.44.0 release)

Post by AnyOldName3 » 31 Jul 2018, 01:11

That I've personally experienced:

The drivers for my printer (a normal apt-get upgrade broke them and they never worked again, but have had no issues under Ubuntu).
Some aspect of Samba (but I can't remember what and it might have been because I was doing something wrong or a guide I was following was wrong).
XBMC/Kodi.
The Windows Media Centre remote we had lying around (which worked intermittently with XBMC/Kodi under Mint after some hassle to get it detected, but perfectly under Ubuntu when it was just plugged in).
Just about everything possible on a computer with an older, but supposedly supported GPU, but that was fixed with KDE Mint, so it might have just been Cinnamon being overconfident about its backwards compatibility.

None of these things should have broken, but they all did during the period when my dad kept installing Mint on things because a friend of his said that 'everybody says Mint is best'. I've had a plethora of issues with Stock Ubuntu, but they've nearly all been my own fault for meddling with something before I knew what it might break. Parts of mint broke which I hadn't touched.
AnyOldName3, Master of Shadows

User avatar
rstevenson1976
Posts: 56
Joined: 14 Apr 2015, 03:55
Location: North Carolina, USA

Re: found a huge issue in the new release (0.44.0 release)

Post by rstevenson1976 » 31 Jul 2018, 01:22

so you're saying that the GPU diver caused those apps to use so much ram that it hard-locks your computer? or you're sure that CUPS just blocked them from running?

User avatar
AnyOldName3
Posts: 1192
Joined: 26 Nov 2015, 03:25

Re: found a huge issue in the new release (0.44.0 release)

Post by AnyOldName3 » 31 Jul 2018, 11:42

No, I was saying that Mint tweaked something so that something that worked fine under stock Ubuntu didn't work. The causal link I suggested was just an example of what might be happening just to illustrate that Mint might be doing something that OpenMW isn't expecting as, at least in my experience, it's done things that other pieces of software didn't expect.

You'd said that we shouldn't be so quick to blame your OS when someone suggested that you tried to replicate the issue under stock Ubuntu as if it was impossible for that to be the cause of or related to the issue, but we know that there's something about your system which isn't the same on any developer's machine that's triggering the problem. We can't work out what that might be unless you can change some things and still have the issue appear.
AnyOldName3, Master of Shadows

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests