[WIP] Android port testing

For new and upcoming OpenMW branches and ports; move fast and break things!
Locked
Mamman3300
Posts: 2
Joined: 31 Jul 2018, 10:56

Re: [WIP] Android port testing

Post by Mamman3300 » 31 Jul 2018, 11:02

Hi just installed and played morrowind for the first time in my life and i am in love. Game runs smoothly with the occasional frame drop and once in a while crash. Only problem i have is the water issue. Would really appreciate if someone can tell me how to fix this.

mojoswagger1980
Posts: 192
Joined: 04 May 2018, 05:16

Re: [WIP] Android port testing

Post by mojoswagger1980 » 03 Aug 2018, 03:11

Mamman3300 wrote:
31 Jul 2018, 11:02
Hi just installed and played morrowind for the first time in my life and i am in love. Game runs smoothly with the occasional frame drop and once in a while crash. Only problem i have is the water issue. Would really appreciate if someone can tell me how to fix this.
try running it under opengles2 grraphics lib.

mojoswagger1980
Posts: 192
Joined: 04 May 2018, 05:16

Re: [WIP] Android port testing

Post by mojoswagger1980 » 03 Aug 2018, 03:13

MistFuror wrote:
31 Jul 2018, 09:04
mojoswagger1980 wrote:
31 Jul 2018, 05:25
your crashing on cell transition . try disabling preload instances . navigate to /sdcard/android/data/com.libopenmw.openmw/config/openmw/ locate the file entitled settings.cfg and open it as a text file . you will see a rather incomplete list of settings. back in the root of com.libopenmw.openmw there is a folder named openmw. inside it is a file named default-settings.cfg . open it as a text file and there you shoukd see the complete list of settings. you need to edit the ones you want changed into the previous file i haf you navigate to first. in this case its in the catagory named cells . you also need to add the category if it isnt in the settings.cfg file. if you need additional help or explanation let me know.
I tried that, have the same problem like many, crashing on cell transitions. Didn't work for me...
hmmm maybe try skipping that part . hit tilde to bring up the console (~) and a couple pahes back i linked the console command wiki.

MistFuror
Posts: 9
Joined: 11 Apr 2018, 20:23

Re: [WIP] Android port testing

Post by MistFuror » 03 Aug 2018, 05:06

Crashes on every cell transition, not just ship

Mamman3300
Posts: 2
Joined: 31 Jul 2018, 10:56

Re: [WIP] Android port testing

Post by Mamman3300 » 03 Aug 2018, 06:16

mojoswagger1980 wrote:
03 Aug 2018, 03:11
Mamman3300 wrote:
31 Jul 2018, 11:02
Hi just installed and played morrowind for the first time in my life and i am in love. Game runs smoothly with the occasional frame drop and once in a while crash. Only problem i have is the water issue. Would really appreciate if someone can tell me how to fix this.
try running it under opengles2 grraphics lib.
I have, but the missing ground and building interior textures isn't encouraging. I found a way by messing with the settings but it ends up making the frame rate drop badly.

mojoswagger1980
Posts: 192
Joined: 04 May 2018, 05:16

Re: [WIP] Android port testing

Post by mojoswagger1980 » 09 Aug 2018, 16:17

Mamman3300 wrote:
03 Aug 2018, 06:16
mojoswagger1980 wrote:
03 Aug 2018, 03:11
Mamman3300 wrote:
31 Jul 2018, 11:02
Hi just installed and played morrowind for the first time in my life and i am in love. Game runs smoothly with the occasional frame drop and once in a while crash. Only problem i have is the water issue. Would really appreciate if someone can tell me how to fix this.
try running it under opengles2 grraphics lib.
I have, but the missing ground and building interior textures isn't encouraging. I found a way by messing with the settings but it ends up making the frame rate drop badly.
No that isn't good. Failing to render the interior environment is a bad sign. What device are you using . that's the first I've heard of complete failure under either lib. (Water doesn't render for me if the shader is on in opengles2 but its documented as being broken and shaders never work right on ported games on android in my experience, opengles just can't cut it in this regard)

mojoswagger1980
Posts: 192
Joined: 04 May 2018, 05:16

Re: [WIP] Android port testing

Post by mojoswagger1980 » 09 Aug 2018, 19:21

MistFuror wrote:
03 Aug 2018, 05:06
Crashes on every cell transition, not just ship
Barring anything unforseen (i.e. you are on android 8.0 and your tryingbto run this with the vulcan api or opengl skia***this one works but it screws up my app drawer layout vulcan crashes it instantly doesnt even make it to launcher) then the cells are failing to load in time . you can disable preload instancing (it really doesnt have much impact on gameplay) you can disable preload doors (more impact but playable) or disable all preload (game loads at every cell change, kind of kills your momentum, not recommended) you can limit the maximum framerate to 60(strongly recommended it sets itself at 240 by default if it is set on 0) you can increase the preload prediction time and distance (this is another strongly recommended) you can increase/decrease cache and preload cache (meh.....i set the minimum to the same as the max really cant see it as having that much impact) and if you can live without audio you can get rid of it . the game is using 4 threads by default, a gfx, an audio, a preload, and a game logic thread, you can completely eliminate 2 and run the engine, but i suggest not completely disabling preload
unless absolutely necessary as it causes so much loading .

mojoswagger1980
Posts: 192
Joined: 04 May 2018, 05:16

Re: [WIP] Android port testing

Post by mojoswagger1980 » 11 Aug 2018, 21:12

Tamriel Rebuilt Update

thats pretty much it. Dont know if anyone else is playing it but they just released Old Ebonheart. the update isnt available on mod nexus however . has to be downloaded from Drive via a link on there web page.

mojoswagger1980
Posts: 192
Joined: 04 May 2018, 05:16

Re: [WIP] Android port testing

Post by mojoswagger1980 » 12 Aug 2018, 08:02

Slight Resolution Change .

If i enable fling or the onscreen navbar and do not use expanded desktop, the horizontal resolution changes from 2560 to 2387 on my note 5 . not sure if or how that helps, but ive been trying to change the resolution since April and that amounts to heing the only successful attempt sort of.....i actually forgot to disable it, i knew it caused a graphical glitch when using it in expanded mode, but was unaware of the slight impact it had on screen resolution when not in expanded.

Trev186
Posts: 4
Joined: 13 Aug 2018, 16:37

Re: [WIP] Android port testing

Post by Trev186 » 13 Aug 2018, 16:40

Hi

How do I open the console?

~ in the virtual input does not work not does any command I enter there

Locked

Who is online

Users browsing this forum: No registered users and 0 guests