[WIP] Android port testing

General discussion regarding the OpenMW project.
For technical support, please use the Support subforum.
JUSTs
Posts: 1
Joined: 20 Apr 2018, 12:58

Re: [WIP] Android port testing

Post by JUSTs » 20 Apr 2018, 13:05

android 6.0.1 "unfortunatly openmw stopped" catlog and config included:
com.libopenmw.openmw_preferences.xml
(349 Bytes) Downloaded 12 times
2018-04-20-14-53-12.txt
(5.63 KiB) Downloaded 15 times

Kjoght
Posts: 3
Joined: 13 Apr 2018, 00:47

Re: [WIP] Android port testing

Post by Kjoght » 21 Apr 2018, 20:29

Game crash when I leavin' ship.
Attachments
openmw-log.txt
Openmw log
(31.63 KiB) Downloaded 13 times

xyzz
Posts: 41
Joined: 14 Jan 2018, 22:25

Re: [WIP] Android port testing

Post by xyzz » 21 Apr 2018, 20:47

I've pushed a hotfix to address the issue with water not being displayed in GLESv2 mode:

- Fixed water not displaying with GLESv2 renderer
- Updated gl4es to 509d3843b2fe273eec85a8242a7ddab62be8bad0

MistFuror
Posts: 6
Joined: 11 Apr 2018, 20:23

Re: [WIP] Android port testing

Post by MistFuror » 21 Apr 2018, 20:53

Also still crashing when I leave the ship ever since the update from OSG 3.4.1 I think. Is it possible that you post a new version but reverted back to OSG 3.4.1 please?

Kjoght
Posts: 3
Joined: 13 Apr 2018, 00:47

Re: [WIP] Android port testing

Post by Kjoght » 21 Apr 2018, 21:49

xyzz wrote:
21 Apr 2018, 20:47
I've pushed a hotfix to address the issue with water not being displayed in GLESv2 mode:

- Fixed water not displaying with GLESv2 renderer
- Updated gl4es to 509d3843b2fe273eec85a8242a7ddab62be8bad0
omg, this is work. U AWESOME, thx you:-)

User avatar
Zanarkan
Posts: 8
Joined: 21 Apr 2018, 22:07
Contact:

Re: [WIP] Android port testing

Post by Zanarkan » 21 Apr 2018, 22:45

1. Sorry for my bad english.
Samsung galaxy tab 7.0 WiFi

The game Fps is not so bad set Fps 30 + modification (mod) all working great. Only for 1 problem the water in glesv1 no water and glesv2 water display but low Fps + missing texture.
I fix the water by changing the value (openmw.cfg) of all lines
like this : fallback=Weather_Clear_Land_Fog_Day_Depth,.0
All Land Fog values set to 0
Now i have water but the fog is a white wall... :evil:
Very bad immersion.
Again Sorry for my bad english.
Thank You very much for this port to android.
This is a dream (honest) to play morrowind on my Tab.
DONT GIVE UP !
Last edited by Zanarkan on 22 Apr 2018, 23:33, edited 1 time in total.
I mean... never ended story !
Black and white pugatory !
Forever back stab story !
B W hystory !
Eat my holy city !
Do You see ?

User avatar
Zanarkan
Posts: 8
Joined: 21 Apr 2018, 22:07
Contact:

Re: [WIP] Android port testing

Post by Zanarkan » 21 Apr 2018, 23:03

Glesv1 no water display
Glesv2 water display (missing textures)
Glesv2 + Glesv1 water shaders and reflection doesn't display well.


Ps : I will not spam this forum.
Just post my test of every New Apk Update.
Last edited by Zanarkan on 23 Apr 2018, 00:09, edited 2 times in total.
I mean... never ended story !
Black and white pugatory !
Forever back stab story !
B W hystory !
Eat my holy city !
Do You see ?

User avatar
synapt3c
Posts: 5
Joined: 10 Apr 2018, 23:46
Contact:

Re: [WIP] Android port testing

Post by synapt3c » 21 Apr 2018, 23:34

The game now works beautifully with my Dual Shock 4! Only minor issue I'm having is the mouse cursor disappearing in some areas of the screen, but it's usable.

Michaelhanesh
Posts: 5
Joined: 05 Apr 2018, 05:19

Re: [WIP] Android port testing

Post by Michaelhanesh » 22 Apr 2018, 13:33

The water is fixed now! Awesome!
I have been testing mods, Tamriel Rebuilt works great athough slow in some parts, Arktwend runs but its very buggy and you cant go past the tutorial, still pretty impressive IMO

MrSpud
Posts: 2
Joined: 22 Apr 2018, 16:05

Re: [WIP] Android port testing

Post by MrSpud » 22 Apr 2018, 16:15

First of all, thank you very much for porting openmw to android, it's like a dream come true! I'm about to update to the new version, I did a backup of my savegames, I just want to know what else I need to backup so I don't have to reconfigure my mods and my UI layout. Is it just the configuration file? Should I copy everything that's in the config folder? I assume I need to uninstall openmw before installing the new version? Thanks.

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests