[WIP] Android port testing

General discussion regarding the OpenMW project.
For technical support, please use the Support subforum.
Post Reply
krupepe55
Posts: 21
Joined: 01 Feb 2018, 13:31

Re: [WIP] Android port testing

Post by krupepe55 » 18 Feb 2018, 19:50

I played with couple of mod, and it does work just like any regular openmw on other system, tribunal delay, patch for purists, optimisation patch, and so on.
I have tried tamriel rebuilt, with same results :). Old ebonheart is not performance friendly :D but it seems like huge city. And other than minor fps drops, it works like a charm.
One thing that I couldn't do is, delete bought spell, in vanilla, maybe in openmw on pc, you just shift+left click and you will be prompted to delete a spell if my memory serves well.
Is it possible to implement this somehow?
Thank you Xyzz
One more question, what is on target overlay button for?

Mrzombieghost2
Posts: 6
Joined: 01 Feb 2018, 03:09

Re: [WIP] Android port testing

Post by Mrzombieghost2 » 19 Feb 2018, 00:25

I played with couple of mod, and it does work just like any regular openmw on other system, tribunal delay, patch for purists, optimisation patch, and so on.
I have tried tamriel rebuilt, with same results :). Old ebonheart is not performance friendly :D but it seems like huge city. And other than minor fps drops, it works like a charm.
One thing that I couldn't do is, delete bought spell, in vanilla, maybe in openmw on pc, you just shift+left click and you will be prompted to delete a spell if my memory serves well.
Is it possible to implement this somehow?
Thank you Xyzz
One more question, what is on target overlay button for?
How did you mod it? Please tell. Did the mods need to be activated?

Ibhram
Posts: 11
Joined: 30 Jan 2018, 11:48

Re: [WIP] Android port testing

Post by Ibhram » 19 Feb 2018, 17:18

Any way to keep subtitles activated? Ive been trying but I cat find a way and I tend to play without sound :/ It has to do with the game rewriting the config on each launch?

Gunselaz
Posts: 1
Joined: 20 Feb 2018, 13:25

Re: [WIP] Android port testing

Post by Gunselaz » 20 Feb 2018, 13:32

Hi thank you so much for this port. Please add the abilitty to read cyrilic enconding. It is important. A lot of people wants to play in russian language. Believe me there is really huge fan base of TES and Morrowind especially in this area.

At least tell how to do it?

Mediacomm
Posts: 2
Joined: 08 Feb 2018, 16:45

Re: [WIP] Android port testing

Post by Mediacomm » 24 Feb 2018, 05:15

krupepe55 wrote:
18 Feb 2018, 19:50
I played with couple of mod, and it does work just like any regular openmw on other system, tribunal delay, patch for purists, optimisation patch, and so on.
I have tried tamriel rebuilt, with same results :). Old ebonheart is not performance friendly :D but it seems like huge city. And other than minor fps drops, it works like a charm.
One thing that I couldn't do is, delete bought spell, in vanilla, maybe in openmw on pc, you just shift+left click and you will be prompted to delete a spell if my memory serves well.
Is it possible to implement this somehow?
Thank you Xyzz
One more question, what is on target overlay button for?
Are you trolling or did you really get mods to work and if so, how?

krupepe55
Posts: 21
Joined: 01 Feb 2018, 13:31

Re: [WIP] Android port testing

Post by krupepe55 » 24 Feb 2018, 10:36

Just like regular openmw, i have edited openmw and settings to manually add and activate mods.
For example, fps cap, force subtitles, so you havent activate it manually everytime time, best attack, prevent merchants from equipment on, owner tooltip, and so on, even load up my save default, without have to select as you can see in gif.
Spoiler: Show
I show you two gifs, one loading mods, and tamriel rebuilt ingame.
https://imgur.com/gallery/KdkZD

Frjemdling
Posts: 3
Joined: 24 Feb 2018, 12:59

Re: [WIP] Android port testing

Post by Frjemdling » 24 Feb 2018, 13:08

This looks really cool! Though I'm having a bit of trouble with launching it. Everytime I boot it up a window appeared with "Could not find Morrowind.bsa"
The path is correct (Well I think) and the .bsa is also in the data folder. Does anybody here maybe know what I did wrong?

Here is how I did it:
  • Made a folder in my local storage
  • Copied Data-Files into that folder
  • Path: /Emu/Data-Files/
I'm on a Huawei P10 Light if that matters anything.

Thanks in advance!

Ibhram
Posts: 11
Joined: 30 Jan 2018, 11:48

Re: [WIP] Android port testing

Post by Ibhram » 24 Feb 2018, 13:50

Krupepe, what file did you exactly modified? I find config/openmw/settings.cfg and /openmw/settings-default.cfg in the /android/data/com.libopenmw.openmw folder... changing either or both do not change nothing ingame, they get reseted on launch.

What did you modified and how?

Another question... installing new meshes its just copyin their folder into ingame folder meshes right?

Fjrem: install a file manager like total commander and check the complete route to your data-file folder... in my case its /storage/emulated/0/mw/data-files

Frjemdling
Posts: 3
Joined: 24 Feb 2018, 12:59

Re: [WIP] Android port testing

Post by Frjemdling » 24 Feb 2018, 16:09

Thanks for the reply! According to Total Commander the path should be "/Storage/6AFD-9809/OpenMW/Data-Files/''. But it still gives the "Archive 'Morrowind.bsa' not found" error, sadly enough. I already tried moving the Data Folder to another location (Local and on SD), but nothing. Would you by chance know what else could cause this error?

Ibhram
Posts: 11
Joined: 30 Jan 2018, 11:48

Re: [WIP] Android port testing

Post by Ibhram » 24 Feb 2018, 16:30

Afaik the game has to be in the internal memory, not in the SD. Apart from that, check spelling on the path and get sure to follow the instructions on the first post in this thread. If that does not wok... I have no clue.

Post Reply

Who is online

Users browsing this forum: Baidu [Spider] and 5 guests