Page 1 of 1

Problem installing animations.

Posted: 11 Jan 2018, 23:07
by Dolos
I'm having a strange problem where even after I replace the vanilla files with the ones from "https://www.nexusmods.com/morrowind/mod ... escription" the animations remain vanilla in game. It's been a very long time since I played (let alone modded) Morrowind, so maybe I'm doing something wrong. But all the instructions say to do is merge the 'Meshes' folders together. The copy of Morrowind came from GOG, if that changes anything.

Re: Problem installing animations.

Posted: 12 Jan 2018, 13:12
by imec
In OpenMW you never need (or want really) to overwrite any of the default files in your Data folder. Simply add something like "data=c:/mymodfolder/nameofmod" line to the end of your config.cfg (located in documents/mygames/openmw on Windows and ~/.config/openmw on Linux) and OpenMW will override things virtually at run time without dirtying your base install.

That said, I tried installing this mod and it seemed to work fine. Are you sure that you are actually overwrite your files and not just placing a folder containing the meshes into your Data folder where they won't be seen by the game?

Re: Problem installing animations.

Posted: 12 Jan 2018, 13:30
by Dolos
I just followed the instructions for the mod: Merge the Meshes folder into the Data/Meshes folder. I did that, but animations stayed the same. I probably should have mentioned that I'm running Manjaro+Cinnamon, sorry.

Re: Problem installing animations.

Posted: 12 Jan 2018, 15:18
by Dolos
imec wrote:
12 Jan 2018, 13:12
That said, I tried installing this mod and it seemed to work fine. Are you sure that you are actually overwrite your files and not just placing a folder containing the meshes into your Data folder where they won't be seen by the game?
When extracted, the archive has a 'Meshes' folder containing four files, I take the files and put them in the "Data\ Files/Meshes" folder and tell Nemo to overwrite the files. Nothing changes though. I'll try the other way and see if I have more luck.

Re: Problem installing animations.

Posted: 12 Jan 2018, 18:31
by Chris
Dolos wrote:
12 Jan 2018, 13:30
I just followed the instructions for the mod: Merge the Meshes folder into the Data/Meshes folder. I did that, but animations stayed the same. I probably should have mentioned that I'm running Manjaro+Cinnamon, sorry.
"Merging" directories and overwriting files like this on Linux is a problem, especially for a game that was originally designed for Windows with a case-insensitive filesystem. If you have a file like Meshes/Foo/Bar.nif and you extract Meshes/Foo/bar.nif, on Windows it will overwrite the first file but on Linux you'll have two files, Meshes/Foo/Bar.nif and Meshes/Foo/bar.nif. OpenMW handles case-insensitive filenames (so if it asks for meshes/foo/bar.nif, it'll still find the original Meshes/Foo/Bar.nif file), but when there's two files whose names only differ by case, there's no way to know which is the intended one to use.

Separate data directories helps solve this, as each data 'source' is managed individually. If one data directory has Meshes/Foo/Bar.nif, and another data directory has Meshes/foo/bar.nif, OpenMW will know these are for the same resource and correctly picks the one with higher priority (determined by the ordering of the data= lines in openmw.cfg).

Re: Problem installing animations.

Posted: 12 Jan 2018, 18:56
by scrawl
Would it be a good idea for us to write a warning to the log file in that case (i.e. a data path that includes the same file twice)?

Re: Problem installing animations.

Posted: 12 Jan 2018, 20:16
by AnyOldName3
Almost certainly, although I'd potentially make it disableable or off when case folding is turned off.

Re: Problem installing animations.

Posted: 13 Jan 2018, 00:08
by Dolos
Seems you were right, there was a case difference between the files... Probably should have realized the possibility, but I was kinda sleep deprived at the time. Thanks for the help. :oops: