/usr/local/lib/libSDL2.so: error adding symbols: File in wrong format

General discussion regarding the OpenMW project.
For technical support, please use the Support subforum.
User avatar
akortunov
Posts: 222
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation
Github profile: https://github.com/akortunov

Re: /usr/local/lib/libSDL2.so: error adding symbols: File in wrong format

Post by akortunov » 24 Dec 2017, 16:08

drpurpul wrote:
24 Dec 2017, 16:03
How do I remove libsdl 2.0.7 I just make installed? By manually deleting it?
There should be "make uninstall" from SDL source folder, or something similar.

drpurpul
Posts: 10
Joined: 24 Dec 2017, 13:41
Github profile: http://github.com/andras-kiss

Re: /usr/local/lib/libSDL2.so: error adding symbols: File in wrong format

Post by drpurpul » 26 Dec 2017, 19:35

Ok, I don't know what the hell I'm doing. I've started from a new debian 9 install, and upon running "cmake ../", openmw says it needs openscenegraph 3.3.4, but all I have is 3.2.3. I've looked up all the debian repositories, and the most recent is also 3.2.3 (sid). Should I then compile from git source? The wiki says debian 9 has all the required dependencies for building openmw, but I think that statement is outdated. So, I guess what I would like to know is how can I install openmw 0.43 in the most safe and clean way on debian 9? Thank you again for making openmw, and thank you for any advise.

User avatar
AnyOldName3
Posts: 727
Joined: 26 Nov 2015, 03:25

Re: /usr/local/lib/libSDL2.so: error adding symbols: File in wrong format

Post by AnyOldName3 » 26 Dec 2017, 21:11

There's a chance that you can get the Ubuntu PPA's version of OSG to work on your machine, but I imagine that would be a nightmare. Otherwise, you're going to have to get OpenMW's OSG fork and build it yourself.

Otherwise, if you don't need to build it yourself, there's both a flatpack and a generic Linux build available from the downloads page.
AnyOldName3, Master of Shadows

drpurpul
Posts: 10
Joined: 24 Dec 2017, 13:41
Github profile: http://github.com/andras-kiss

Re: /usr/local/lib/libSDL2.so: error adding symbols: File in wrong format

Post by drpurpul » 26 Dec 2017, 21:54

Thank you for the advice. I've managed to compile it successfully. I've realized, that there is "libopenscenegraph-3.4-130" and "libopenscenegraph-3.4-dev" in the debian stretch repository besides "libopenscenegraph100v5" and "libopenscenegraph-dev". The latter two are version 3.2.3 (I think), which is below the required version for openmw. So what I did to compile it on debian 9.3:

I've installed SDL2-2.0.7 from https://www.libsdl.org/ by make install. I know it's not exactly the best solution. then:

sudo apt-get install libopenscenegraph-3.4-130
sudo apt-get install libopenscenegraph-3.4-dev
git clone https://github.com/OpenMW/openmw
cd openmw
mkdir build
cd build
cmake ../
make -j`getconf _NPROCESSORS_ONLN`

Post Reply

Who is online

Users browsing this forum: Sonny101 and 4 guests