OpenMW freezes computer with video

General discussion regarding the OpenMW project.
For technical support, please use the Support subforum.
ezze
Posts: 428
Joined: 21 Nov 2013, 13:20

Re: OpenMW freezes computer with video

Post by ezze » 06 Apr 2017, 09:50

To check if it is a "swap is so slow that everything look frozen"-problem try to setup ulimits just a bit less than your real RAM.
For example, just before OpenMW execute ulimit -v 4096000 and ulimit -m 4096000. (The number is 4 * 1024 * 1000, a bit less than 4GB).

Or, arguably simpler, temporarily disable swap altogether.


If OpenMW runs out of memory, it will crash before becoming frozen for swapping. Your machine might be unresponsive while the kernel writes the core dump though.

argonvegell
Posts: 182
Joined: 08 Dec 2015, 23:45

Re: OpenMW freezes computer with video

Post by argonvegell » 13 Apr 2017, 03:20

ezze wrote:To check if it is a "swap is so slow that everything look frozen"-problem try to setup ulimits just a bit less than your real RAM.
For example, just before OpenMW execute ulimit -v 4096000 and ulimit -m 4096000. (The number is 4 * 1024 * 1000, a bit less than 4GB).

Or, arguably simpler, temporarily disable swap altogether.


If OpenMW runs out of memory, it will crash before becoming frozen for swapping. Your machine might be unresponsive while the kernel writes the core dump though.
Sorry Ezze, this went over my head, I'm not tech-savy, so this confused me.

Anyway to fix this issue, I'd really like to use distant terrain.

I activated distant terrain and looked at my RAM usage with HardInfo 0.5.1, it looks like distant terrain is really zapping my memory, I even disabled preloading.

SquireNed
Posts: 401
Joined: 21 Dec 2013, 22:18

Re: OpenMW freezes computer with video

Post by SquireNed » 14 Apr 2017, 00:43

argonvegell wrote:
ezze wrote:To check if it is a "swap is so slow that everything look frozen"-problem try to setup ulimits just a bit less than your real RAM.
For example, just before OpenMW execute ulimit -v 4096000 and ulimit -m 4096000. (The number is 4 * 1024 * 1000, a bit less than 4GB).

Or, arguably simpler, temporarily disable swap altogether.


If OpenMW runs out of memory, it will crash before becoming frozen for swapping. Your machine might be unresponsive while the kernel writes the core dump though.
Sorry Ezze, this went over my head, I'm not tech-savy, so this confused me.

Anyway to fix this issue, I'd really like to use distant terrain.

I activated distant terrain and looked at my RAM usage with HardInfo 0.5.1, it looks like distant terrain is really zapping my memory, I even disabled preloading.
Distant terrain and preloading share a fair number of similarities in terms of RAM impact.

Post Reply