Page 2 of 2

Re: Object Lighting Glitch

Posted: 02 Mar 2016, 11:50
by mym
Thanks for the explanation.

Re: Object Lighting Glitch

Posted: 02 Mar 2016, 12:10
by psi29a
scrawl wrote:Well, I'm tired of not owning the affected hardware to diagnose this issue myself, so I ordered a HD 6450 on ebay. When it gets here I'll look into the issue and try to find a workaround.
Now that is dedication! Cheers man! :D

Re: Object Lighting Glitch

Posted: 02 Mar 2016, 13:57
by lysol
psi29a wrote:
scrawl wrote:Well, I'm tired of not owning the affected hardware to diagnose this issue myself, so I ordered a HD 6450 on ebay. When it gets here I'll look into the issue and try to find a workaround.
Now that is dedication! Cheers man! :D
Hahaha, yes, the word dedication just got redefined.

Re: Object Lighting Glitch

Posted: 03 Mar 2016, 16:08
by scrawl
Quick update. Got the HD 6450 installed, fired up OpenMW 0.38. Didn't see any bugs with the default (open source) driver. But with the proprietary fglrx driver installed, I do have the lighting glitch. This further increased my suspicion that AMD is to blame. But let's not jump to conclusions yet.
fglrx.png
Now I need to set up a development environment on this PC so that I can start trying workarounds. Hopefully I have enough space for that, it's all running off a live USB stick.

Btw, I was surprised how well OpenMW runs on this potato card that cost 15 bucks. Never dropped below 60 fps even in cities. It is slightly faster with the fglrx driver, but the open source driver was performing very good as well.

Re: Object Lighting Glitch

Posted: 03 Mar 2016, 16:18
by psi29a
scrawl wrote:Btw, I was surprised how well OpenMW runs on this potato card that cost 15 bucks. Never dropped below 60 fps even in cities. It is slightly faster with the fglrx driver, but the open source driver was performing very good as well.
This needs to go on the blog... emphasis mine.

Re: Object Lighting Glitch

Posted: 03 Mar 2016, 21:22
by scrawl
What I've gathered so far is, the driver for some reason sets the glColorMaterial to GL_EMISSION, even though we're not telling it to.

Using shaders (i.e. enabling the 'force shaders' option added in OpenMW 0.39) works around the issue. So, if you're affected, just use the nightly builds, and add this line to your settings file:

Code: Select all

[Shaders]
force shaders = true
I'm still looking for other workarounds.

Re: Object Lighting Glitch

Posted: 29 Mar 2016, 20:32
by Svetomech
The similar bug is also present when running the game on Intel HD 4000. I know, it's really not a videocard one would use to play videogames, but I'm in dire need of prolonged battery life (besides, switching to Radeon HD 7670M that my laptop also has does only help if I don't activate the water shader, enabling it ~equates FPS on both videocards).

Re: Object Lighting Glitch

Posted: 28 Sep 2016, 21:37
by GameEnder
I did some looking in to this lighting problem on Windows and found that Driver 13.12 was the last driver version that the lighting bug dose not happen on.


A archive of old drivers from 3DGuru has a copy of the 13.12 Opengl DLL's. https://mega.nz/#F!8tlAhDyQ!2AkAQukJKAY ... A!g4tTiZ7A Putting those DLL's in the OpenMW directory fixes the problem completely with zero performance difference from what I can tell on both a R7-250 & a R9-290.

I anyone has some experience in driver hacking could look at these and compare them and create some kind of better workaround?

Re: Object Lighting Glitch

Posted: 29 Jul 2017, 21:56
by scrawl
Hell froze over AMD fixed the bug! Or so they say.
Re: Incorrect OpenGL fixed function rendering
dwitczak
dwitczak Employee Feb 23, 2017 3:53 AM (in response to pchiruma)

This issue has been fixed internally. One of the coming driver releases should start to work as expected. Thanks for reporting!
Anyone know if there has been a new driver since?

In any case, a user on reddit suggests another potential workaround:
[OpenMW] I found a fix for the AMD flickering tree bug. (self.Morrowind)
You have to change the Anti-Aliasing settings in Catalyst Control Center to Adaptive Multisampling.

Re: Object Lighting Glitch

Posted: 30 Jul 2017, 12:00
by damiel
scrawl wrote:
29 Jul 2017, 21:56
Hell froze over AMD fixed the bug!
Haha, thanks for that piece of joy scrawl :D