Object Lighting Glitch

General discussion regarding the OpenMW project.
For technical support, please use the Support subforum.
strudo76
Posts: 6
Joined: 08 Jan 2016, 04:10

Object Lighting Glitch

Post by strudo76 » 18 Feb 2016, 02:27

Is this something I should expect as a quirk of the engine, or is there a problem with my files somewhere?

Image

I get this effect a lot, indoors and outdoors, day or night, big objects like this shot, or small items like rings sitting on tombs. Some objects appear to be lit way brighter than the rest of the scene. Move the mouse a few pixels in any direction and it returns to normal, a few more and it back again. Most pronounced when the view is in the more level position, looking upwards or downwards tends to make it occur less. Can be quite irritating when moving around dungeons having random objects flicker bright and dull as I move the view around the screen. Not sure if it's just the engine still having a few quirks, or if a mod is to blame, or something else. Using the current release 0.38.0 OpenMW on Windows 10 with current AMD drivers.

DXDiag

morrowind.ini from installation location used to import settings. I also have the mod Animation Compilation which doesn't have an esp file listed under game files.

openmw.log from last session

Can post any other information required.

Regards,

Simon

User avatar
scrawl
Posts: 2152
Joined: 18 Feb 2012, 11:51

Re: Object Lighting Glitch

Post by scrawl » 18 Feb 2016, 02:34

This is a widely encountered issue that I currently suspect to be an AMD driver bug.

That said, the shaders branch, which should be merged soon, makes some changes to the lighting system that may work around the bug.

strudo76
Posts: 6
Joined: 08 Jan 2016, 04:10

Re: Object Lighting Glitch

Post by strudo76 » 18 Feb 2016, 04:37

Coolies. I'll just grim and bear it for the time being then. Going back to NVidia seems to be a more appealing option all the time.

User avatar
scrawl
Posts: 2152
Joined: 18 Feb 2012, 11:51

Re: Object Lighting Glitch

Post by scrawl » 01 Mar 2016, 15:45

Hi,
can you test if you still have this issue in Ace's latest nightly build? This build includes some changes to the lighting system that may fix the glitched rendering with AMD cards.

User avatar
bahamut
Posts: 35
Joined: 16 Apr 2014, 11:46

Re: Object Lighting Glitch

Post by bahamut » 01 Mar 2016, 19:10

scrawl wrote:Hi,
can you test if you still have this issue in Ace's latest nightly build? This build includes some changes to the lighting system that may fix the glitched rendering with AMD cards.
If its same thing, i still got a lightning bug in Census and Excise while looking at quill on desk next to Socucius Ergalla (nightly x64)

User avatar
scrawl
Posts: 2152
Joined: 18 Feb 2012, 11:51

Re: Object Lighting Glitch

Post by scrawl » 01 Mar 2016, 19:27

It may be a different issue - can you post screenshot(s)?

User avatar
bahamut
Posts: 35
Joined: 16 Apr 2014, 11:46

Re: Object Lighting Glitch

Post by bahamut » 01 Mar 2016, 20:24


strudo76
Posts: 6
Joined: 08 Jan 2016, 04:10

Re: Object Lighting Glitch

Post by strudo76 » 02 Mar 2016, 09:53

bahamut wrote:
scrawl wrote:Hi,
can you test if you still have this issue in Ace's latest nightly build? This build includes some changes to the lighting system that may fix the glitched rendering with AMD cards.
If its same thing, i still got a lightning bug in Census and Excise while looking at quill on desk next to Socucius Ergalla (nightly x64)
Looks like the same issue. That first room on starting a new game is a great place to see the effect. Happens there every time.

I don't have a save from the screenshot I posted, so I could only look for the same effects in different locations. It's pretty common for me, and mostly in interior areas.

mym
Posts: 42
Joined: 09 Feb 2015, 13:31

Re: Object Lighting Glitch

Post by mym » 02 Mar 2016, 11:03

I also have a similar over lighting bug since about 2 weeks (on master repo).
It happens on 2 hardware configs:
- an intel/nvidia (proprietary drivers)
- an intel/intel integrated gpu

- buildings: Image
- rocks: Image

User avatar
scrawl
Posts: 2152
Joined: 18 Feb 2012, 11:51

Re: Object Lighting Glitch

Post by scrawl » 02 Mar 2016, 11:44

@mym, that's not a bug, it's a side effect of the "fake bump mapping" environment map technique that some MW mods use. These need the Morrowind Code Patch to function as intended. We don't plan on adding this patch to OpenMW because we already have real bump mapping.

As for the white flecks on these rocks, bad specular values (see bug 2277). These would not show up in the original engine because MW did not support specular lighting. Again not a bug, won't fix.

@bahamut: yes, that looks like the infamous AMD lighting glitch is still there.

Well, I'm tired of not owning the affected hardware to diagnose this issue myself, so I ordered a HD 6450 on ebay. When it gets here I'll look into the issue and try to find a workaround.

Post Reply