Complete Playthrough on OpenMW

General discussion regarding the OpenMW project.
For technical support, please use the Support subforum.
SquireNed
Posts: 402
Joined: 21 Dec 2013, 22:18

Re: Complete Playthrough on OpenMW

Post by SquireNed » 05 Jun 2014, 04:22

For what it's worth, it does sort of stop just rapidly accelerating and eventually seems to level out. I'm attaching a zip with four images of my resource monitor after booting up OpenMW, then after loading a game in Seyda Neen, again after walking over to Balmora, and a final time after loading my save because I fell off the cliff overlooking the city too quickly.

Another issue: Cell loading can happen very often on cell transition heavy areas (such as walking along cell borders, which happened a ton in Vivec). I don't remember how this worked in OpenMW, but it might be nice to have some sort of gray zone between the cells in which they aren't yet unloaded but where they will load up; walk around Vivec very long and you'll see what I mean with the transitions.
Attachments
OpenMWRamUse.7z
(241.09 KiB) Downloaded 61 times

SquireNed
Posts: 402
Joined: 21 Dec 2013, 22:18

Re: Complete Playthrough on OpenMW

Post by SquireNed » 05 Jun 2014, 04:56

Is rain/lightning supposed to appear in OpenMW yet? I can hear it, but it's not showing up.

EDIT: I see the lightning, so disregard that part. Still no rain, though, but I get a couple weird artifacts every once in a while when it is "raining".

User avatar
Greendogo
Posts: 1449
Joined: 26 Aug 2011, 02:04

Re: Complete Playthrough on OpenMW

Post by Greendogo » 05 Jun 2014, 05:11

No rain/snow yet! :D

What kind of artifacts?

SquireNed
Posts: 402
Joined: 21 Dec 2013, 22:18

Re: Complete Playthrough on OpenMW

Post by SquireNed » 05 Jun 2014, 05:19

Vertical lines the same color as the maximum view distance fog wherever I am.

Also, my RAM usage has now officially climbed up to 3.7 GB, though OpenMW remains stable and has not suffered a performance hit.

User avatar
psi29a
Posts: 4880
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Complete Playthrough on OpenMW

Post by psi29a » 05 Jun 2014, 07:55

Ram usage is Orge caching assets and not purging them even when asked. Known issues for years now, and is being worked on by Ogre.

SquireNed
Posts: 402
Joined: 21 Dec 2013, 22:18

Re: Complete Playthrough on OpenMW

Post by SquireNed » 05 Jun 2014, 17:16

That probably explains pretty much all of it then, since RAM usage is roughly proportional to distance traveled. Again, other than that OpenMW is relatively well-behaved. I get some crashes if I leave window focus while saving/loading, but this could be a RAM issue or simply Windows doing the "Hey, look, this program isn't responding because it's actually doing something, so do you want to kill it now?" routine it does and making it an issue.

I have now raided a crypt at the bequest of Sul-Matuul. My quest to become Nerevarine has begun, mostly without a hitch. I discovered that grave robbing is a great way to contract diseases. Reading ahead on the walkthrough, it looks like I need to be cursed with Corpus by the next big guy I fight. We'll see how that goes.

SquireNed
Posts: 402
Joined: 21 Dec 2013, 22:18

Re: Complete Playthrough on OpenMW

Post by SquireNed » 12 Jun 2014, 23:39

Caught corpus (and an ability drain effect) perfectly fine, so now I'm off to visit Caius Cossades again.

I've noticed that I have a ton of arrows in my inventory from being shot a ton; these seem to be in a variety of diverse flavors. Skeleton archers are, by far, the most annoying foe I've met, in part because spellcasters don't do their thing yet. Either the OpenMW player controller or Bullet handle much differently than Morrowind's original counterparts do, which leads to some fun little issues with terrain once in a while. I got stuck in Ilunibi while walking along normally a couple of times, though it was short lived every time it happened. I'm not sure if this was a result of low hanging ceiling or a floor issue, since it's too dark there for me to see well (I'm playing with a window to my back, resulting in some hard-to-see scenes).

User avatar
Greendogo
Posts: 1449
Joined: 26 Aug 2011, 02:04

Re: Complete Playthrough on OpenMW

Post by Greendogo » 13 Jun 2014, 01:14

SquireNed wrote:Either the OpenMW player controller or Bullet handle much differently than Morrowind's original counterparts do, which leads to some fun little issues with terrain once in a while. I got stuck in Ilunibi while walking along normally a couple of times, though it was short lived every time it happened. I'm not sure if this was a result of low hanging ceiling or a floor issue, since it's too dark there for me to see well (I'm playing with a window to my back, resulting in some hard-to-see scenes).
That may be a bug that Scrawl recently fixed.

SquireNed
Posts: 402
Joined: 21 Dec 2013, 22:18

Re: Complete Playthrough on OpenMW

Post by SquireNed » 13 Jun 2014, 01:53

It was in an interior cell, but it could very well have been related. I had a couple clipping issues in the wilderness as well, but just chalked it up to the stuff that I walked into not working right (which sounds similar to the reported and fixed bug).

I don't really want to update to a more recent build, though, because then my infinite glitched lockpicks will be a thing of the past. Not that I'd ever exploit a bug or anything like that.

Post Reply