Ogre 1.9 is coming!

General discussion regarding the OpenMW project.
For technical support, please use the Support subforum.
User avatar
Greendogo
Posts: 1384
Joined: 26 Aug 2011, 02:04

Ogre 1.9 is coming!

Post by Greendogo » 23 Apr 2013, 04:28

So the first RC for Ogre 1.9 has been released, and as we all know, Ogre is OpenMW's main graphic engine.

As there has some been some majorish upgrades to Ogre's graphical capabilities (I think) I'm wondering if anyone here has had a chance to play around with it yet, or plans to? Is anyone anticipating upgrading OpenMW to Ogre 1.9 once the RC period is over?

Does 1.9 bring support for OpenGL 3+ and DirectX 11? What exactly is going on there?

User avatar
Zini
Posts: 5536
Joined: 06 Aug 2011, 15:16

Re: Ogre 1.9 is coming!

Post by Zini » 23 Apr 2013, 09:17

Some support for DirectX11 and OpenGL3 has been in OGRE for a while (in various state of completion). Nice to have, but honestly not something I would hyper excited about. Not sure if this stuff is actual usual in 1.9. Looks still pretty fresh. Paint probably not dry yet.

Unless there is a compelling reason (fix for a critical bug or something) I don't see us moving to 1.9 as the primary OGRE version anytime soon.

Edit:

Just found this line:
- Cannot build Ogre using clang with -stdlib=libc++ option on OS X
in the bug fix section of the release notes. @corristo: Does that mean, what I think it means? If it does we are probably moving to 1.9 as soon as it is out of RC state.

User avatar
psi29a
Posts: 4640
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Ogre 1.9 is coming!

Post by psi29a » 23 Apr 2013, 09:25

Zini wrote:
- Cannot build Ogre using clang with -stdlib=libc++ option on OS X
in the bug fix section of the release notes. @corristo: Does that mean, what I think it means? If it does we are probably moving to 1.9 as soon as it is out of RC state.
Waits with bated breath.... 8-)

ezzetabi
Posts: 407
Joined: 03 Feb 2012, 16:52

Re: Ogre 1.9 is coming!

Post by ezzetabi » 23 Apr 2013, 15:16

I am fairly sure it is possible to still use gcc in osx, so it should not be a problem.

User avatar
psi29a
Posts: 4640
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Ogre 1.9 is coming!

Post by psi29a » 23 Apr 2013, 22:37

ezzetabi wrote:I am fairly sure it is possible to still use gcc in osx, so it should not be a problem.
That was a bugfix, meaning gcc AND clang should be good to go with -stdlib=libc++ ;)

User avatar
raevol
Posts: 3016
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: Ogre 1.9 is coming!

Post by raevol » 24 Apr 2013, 02:29

5 posts and this thread is already a rollercoaster...!

User avatar
Greendogo
Posts: 1384
Joined: 26 Aug 2011, 02:04

Re: Ogre 1.9 is coming!

Post by Greendogo » 29 Apr 2013, 04:27

So, was that a yes or a no?

Edit: After seeing Issue #699, I take that as a yes?

User avatar
Zini
Posts: 5536
Joined: 06 Aug 2011, 15:16

Re: Ogre 1.9 is coming!

Post by Zini » 29 Apr 2013, 10:34

That issue is just the usual nonsense we get regarding the resources system with each new OGRE release. Probably something very minor.

I am still waiting for corristo to come back and comment on OS X issue. Obviously we need to run a few tests first (and fix that resources system bug). But if everything works out we will be switching to OGRE 1.9 once it is out of the RC phase.

maqifrnswa
Posts: 180
Joined: 14 Jan 2013, 03:57

Re: Ogre 1.9 is coming!

Post by maqifrnswa » 30 Apr 2013, 19:21

Update re debian and ubuntu ogre packages:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=704044

Debian and Ubuntu currently have 1.8.0, but they just started adding 1.8.1 this week. The next Ubuntu (saucy) and Debian (jessie) will have 1.8.1.

Also, 1.9 will be in Debian (and thus Ubuntu) after ogre is out of RC.

mygui was just accepted as a package in debian main (and thus ubuntu) [1], it's currently built against 1.8.0 but will soon be built against 1.8.1 once it is uploaded. I have made bret curtis an uploader for the package. For now he'll still need a debian sponsor but is a co-maintainer of the debian/ubuntu mygui package. The Debian repository for packaging is here:
http://anonscm.debian.org/gitweb/?p=col ... /mygui.git
access to the repo is granted via debian:
http://lists.debian.org/debian-devel-an ... 00006.html
and bret should have no problem receiving it (I can also upload patches for you in the mean time).

[1] http://packages.debian.org/source/sid/mygui

User avatar
psi29a
Posts: 4640
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Ogre 1.9 is coming!

Post by psi29a » 01 May 2013, 07:28

I talked with MyGUI developer George Evmenov: about Ogre3D 1.9 support:
(08:25:57 AM) bbrick: any problems with mygui and ogre3d 1.9 rc?
(08:26:15 AM) George Evmenov: no
(08:26:46 AM) George Evmenov: well, I doesn't work with Dx11 actually, since it render everything in different way
(08:26:58 AM) George Evmenov: but work just fine with all other render systems
...
(08:28:32 AM) bbrick: is that a future development task (DX11 support) ? :)
(08:28:40 AM) George Evmenov: yeah

Post Reply