Weird lighting

General discussion regarding the OpenMW project.
For technical support, please use the Support subforum.
Post Reply
jonimacarroni
Posts: 14
Joined: 26 Sep 2017, 23:43

Weird lighting

Post by jonimacarroni » 12 Oct 2017, 12:20

I'm not sure if this is supposed to happen, but I seem to have incongruent lighting between not only adjacent cells but also between cells and their objects. I also have that in dark places the player character exudes light without any sort of light spell effect being active. I could not quickly find a spot where adjacent objects have completely opposite lighting, but it seems very common in caves. I will get back here and post a screenshot next time I find that situation.

https://imgur.com/a/BvaQb

User avatar
kuyondo
Posts: 117
Joined: 29 Mar 2016, 17:45

Re: Weird lighting

Post by kuyondo » 12 Oct 2017, 19:14

i think the issue in the 1st and 3rd picture is present in morrowind. im not sure, possibly related to this?->https://bugs.openmw.org/issues/3139

jonimacarroni
Posts: 14
Joined: 26 Sep 2017, 23:43

Re: Weird lighting

Post by jonimacarroni » 12 Oct 2017, 20:18

Thank you, you are apparently correct about the seams!

Now, I still don't understand why my character is emitting light. I will try with a new game later, just to test if it is some bug on my character.
I present here screenshots inside a a cave (eggmine nearest vivec entrance) that show the object lighting problem I had mentioned. As you are able to see, the change is extremely abrupt and noticeable while walking. The rocks even seem like they suddenly pop a texture.

https://imgur.com/a/Vioui

I am sorry if this feels like a menial post, but I haven't been able to play for a full week because of these lighting issues. They completely destroy any immersion for me.

User avatar
kuyondo
Posts: 117
Joined: 29 Mar 2016, 17:45

Re: Weird lighting

Post by kuyondo » 13 Oct 2017, 01:41

Can you reproduce the bug without mods, only the base game? If it is still present, it may well be an engine bug that needs to be addressed in the bugtracker.

User avatar
akortunov
Posts: 144
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation
Github profile: https://github.com/akortunov

Re: Weird lighting

Post by akortunov » 13 Oct 2017, 04:49

jonimacarroni wrote:
12 Oct 2017, 20:18
Now, I still don't understand why my character is emitting light.
Which OpenMW version are you using?
I encountered a similar issue recently on the master git branch (0.43).
There was a bug, which allowed to pick light sources without CanCarry flag from containers.
I use a mod, which adds such light sources to Flame Atronachs, and once I used the "Take All" button.
This bug was already fixed, but I still had to remove already taken light sources from the player's inventory via "removeitem" console command.
Last edited by akortunov on 13 Oct 2017, 13:56, edited 2 times in total.

jonimacarroni
Posts: 14
Joined: 26 Sep 2017, 23:43

Re: Weird lighting

Post by jonimacarroni » 13 Oct 2017, 13:41

kuyondo wrote:
13 Oct 2017, 01:41
Can you reproduce the bug without mods, only the base game? If it is still present, it may well be an engine bug that needs to be addressed in the bugtracker.
I am oing to try that in the next minutes and report back.
akortunov wrote:
13 Oct 2017, 04:49
jonimacarroni wrote:
12 Oct 2017, 20:18
Now, I still don't understand why my character is emitting light.
Which PpenMW version are you using?
I encountered a similar issue recently on the master git branch (0.43).
There was a bug, which allowed to pick light sources without CanCarry flag from containers.
I use a mod, which adds such light sources to Flame Atronachs, and once used "Take All" button.
This bug was already fixed, but I still had to remove already taken light sources from the player's inventory via "removeitem" console command.
I usually use one of the nightlies, and I do have an atronarch replacer mod. I think that might just be my situation. Can you be more specific on how to remove the light sources through the console?

User avatar
akortunov
Posts: 144
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation
Github profile: https://github.com/akortunov

Re: Weird lighting

Post by akortunov » 13 Oct 2017, 13:55

jonimacarroni wrote:
13 Oct 2017, 13:41
I do have an atronarch replacer mod
I mean not only replacer, but a mod with the ESP file.

If it is your case:
1. Open your replacer via editor
2. Check the Flame Atronach inventory
3. There should be a Light item (the "light_misc" in my case)
4. Just remove this item via "removeitem":

Code: Select all

player->removeitem light_misc 100
Note: I do not sure that exactly Flame Atronachs cause this bug. It is can be caused by any container in the game.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests