Help installing OpenMW on Ubuntu 10.10 using the .deb file!

A generic talk on the OpenMW project.
Locked
User avatar
lgromanowski
Site Admin
Posts: 1143
Joined: 05 Aug 2011, 22:21
Location: Wroclaw, Poland
Github profile: https://github.com/lgromanowski
Contact:

Help installing OpenMW on Ubuntu 10.10 using the .deb file!

Post by lgromanowski » 21 Aug 2011, 21:54

Ninwa wrote: Hey all, for the life of me I cannot get the .deb to agree with my system. It insists that I don't have an ogre package installed that meets its requiremets (>=1.7.1) which I really do, I promise. I have 1.7.2 installed.

I've already solicited help over at Ubuntu Forums, and was hoping maybe somebody here was already familiar with the problem. Or maybe, maybe the problem is me. In fact, that's likely too.

Here's my other post: http://ubuntuforums.org/showthread.php?t=1720957

Any help is appreciated. This looks like a very cool project and I'm excited to get it running on my machine so I can start submitting bug reports!
heilkitty wrote: You'd better build it from source then.
raevol wrote:
heilkitty wrote:You'd better build it from source then.
This is not an acceptable response. Either our .deb is broken, or the original poster has Ogre installed wrong.

Ninwa, where is your Ogre installed from?
Peppe wrote:
Ninwa wrote:Hey all, for the life of me I cannot get the .deb to agree with my system.
The package is for Debian (sid) not for Ubuntu so that's not really surprising.
Ninwa wrote:It insists that I don't have an ogre package installed that meets its requiremets (>=1.7.1) which I really do, I promise. I have 1.7.2 installed.
You are misreading the dependency list, it depends on libogremain-1.7.1 (>= 1.7.1-1), so it depends on ogre 1.7.1 but will accept newer versions of 1.7.1 not 1.7.2.

If you want it to work with ogre 1.7.2 you will have to build it.
raevol wrote:
raevol wrote:Ninwa, where is your Ogre installed from?
I read your thread on ubuntuforums, and I see where you got Ogre from now. Yes, you'll need a 1.7.1 Ogre like Peppe said above.

Don't mind me. :P
heilkitty wrote:
raevol wrote:This is not an acceptable response.
I mean, it's better for testing purpose anyway. I didn't mean not to solve problem with deb package.
raevol wrote:
heilkitty wrote:
raevol wrote:This is not an acceptable response.
I mean, it's better for testing purpose anyway. I didn't mean not to solve problem with deb package.
Sorry, I didn't mean to snap at you! :( I agree testing fresher code is better, but a working .deb means more testing will get done period, especially later in development when it's going to be critical.
Ninwa wrote: Hey guys, thank you for all of your responses! I indeed would have been reading the dependency list incorrectly. I will try installing a version >= 1.7.1-1 now and promise to let you know if I can get it working! Thanks again, and look forward to checking out OpenMW :)
Ninwa wrote: I have tried installing libogremain1.7.1 and am still receiving dependency errors from the OpenMW 0.10 debian package.

I checked Ogre's website to see if there are any minor revisions that would make it (>= 1.7.1-1) http://sourceforge.net/projects/ogre/files/ogre/1.7/ and it seems there aren't, at least without really digging.

I'm going to try my hand at packaging a new .deb file to work with 1.7.2 (the latest release) if possible, although 1.6.4 might be preferable because it's in the standard Ubuntu 10.10 repository. Not being familiar with the project I'm not sure what it will and wont compile with.

Cheers,
Ninwa
Zini wrote: There were API changes in Ogre that makes OpenMW incompatible with anything below Ogre 1.7.1.
Ninwa wrote: Great. :)

I was able to get OpenMW built properly. There is a problem with openmw.cfg, but I notice it's already in the tracker. Thanks for the help!

Ninwa

Edit: I've built a working .deb package, posted it in a new thread so that it would be more easily seen.
Peppe wrote:
Ninwa wrote:I have tried installing libogremain1.7.1 and am still receiving dependency errors from the OpenMW 0.10 debian package.
As I wrote previously this is not really surprising, the package is not meant for Ubuntu.
Ninwa wrote:I checked Ogre's website to see if there are any minor revisions that would make it (>= 1.7.1-1) http://sourceforge.net/projects/ogre/files/ogre/1.7/ and it seems there aren't, at least without really digging.
The -1 is the package revision not ogre revision, so if ogre 1.7.1 is by some reason repackaged it would be -2.
Ninwa wrote:
Peppe wrote:
Ninwa wrote:I have tried installing libogremain1.7.1 and am still receiving dependency errors from the OpenMW 0.10 debian package.
As I wrote previously this is not really surprising, the package is not meant for Ubuntu.
Ninwa wrote:I checked Ogre's website to see if there are any minor revisions that would make it (>= 1.7.1-1) http://sourceforge.net/projects/ogre/files/ogre/1.7/ and it seems there aren't, at least without really digging.
The -1 is the package revision not ogre revision, so if ogre 1.7.1 is by some reason repackaged it would be -2.
Ah, thank you for the clarification. :)
best regards,
Lukasz

Locked

Who is online

Users browsing this forum: No registered users and 1 guest