Start exploring OpenMW

A generic talk on the OpenMW project.
Locked
User avatar
lgromanowski
Site Admin
Posts: 1193
Joined: 05 Aug 2011, 22:21
Location: Wroclaw, Poland
Github profile: https://github.com/lgromanowski
Contact:

Start exploring OpenMW

Post by lgromanowski » 21 Aug 2011, 21:16

Master-X wrote: Greetings all!

I'm very interested in the exciting OpenMW project. Today I compiled current git version of OMW and successfully run it.
But I still have some questions (yes, I know, some of them already had their answers on the board, but they're a bit outdated):
1) I'm starting outside a cave. Is it my own lag?
2) Clipping is off. I heard OMW now using Bullet. Is there a way to enable collisions?
3) Touching to objects is laggy, but it's normal due to using OGRE ray-cast. I CAN get the scroll and the torch, and I'm happy :D
4) openmw.cfg contains one line. Is anybody had a plan to add some tuning lines to this file?
5) At this moment I just start reading source, and find out that piece of code:

Code: Select all

enum Actions
    {
      A_Quit,           // Exit the program

      A_Screenshot,     // Take a screenshot

      A_Inventory,      // Toggle inventory screen

      A_Console,        // Toggle console screen

      A_MoveLeft,       // Move player left / right
      A_MoveRight,
      A_MoveUp,         // Move up / down
      A_MoveDown,
      A_MoveForward,    // Forward / Backward
      A_MoveBackward,

      A_Activate,

      A_LAST            // Marker for the last item
    };
Is there some another cheats/hotkeys except described?

6. Can I get outside?
7. The NPCs had their left hands below it's "normal" positions. Is it lag or not?

Thanks for attention!
Kind regards,
Master.

PS. Console output:

Code: Select all

$ ./openmw
Data directory: /media/st0/morrodev/OpenMW/build/data
Adding /media/st0/morrodev/OpenMW/build/data/houseofmannequins.bsa
Adding /media/st0/morrodev/OpenMW/build/data/all_glass_armor.bsa
Adding /media/st0/morrodev/OpenMW/build/data/Ice_ElegantGowns_1C.bsa
Adding /media/st0/morrodev/OpenMW/build/data/Bloodmoon.bsa
Adding /media/st0/morrodev/OpenMW/build/data/Tribunal.bsa
Adding /media/st0/morrodev/OpenMW/build/data/Morrowind.bsa
Adding /media/st0/morrodev/OpenMW/build/data/BetterBodies.bsa
Loading ESM /media/st0/morrodev/OpenMW/build/data/Morrowind.esm
Sound output:  OpenAL
Sound decoder: mpg123,sndfile
loading cell 'Beshara'

Press Q/ESC or close window to exit.
Playing /media/st0/morrodev/OpenMW/build/data/Music/Explore/mx_explore_3.mp3
Error in framelistener: unknown Ogre handle: ????°?¨???¨?? ????? ?­?¤??upper leg
Quitting peacefully.
Zini wrote: 1. You should be starting inside a cave.

2. No bullet yet. Still in the preparation phase

4. You can put other settings in there. We are using a unified settings model, that combines input from the command line, the cfg file and default settings.

5. Nope

6. Use a door or coc. But no terrain yet and slow.
Master-X wrote: Thanks for answer!
What about question
7. The NPCs had their left hands below it's "normal" positions. Is it lag or not?
About using door. I received fail message

Code: Select all

loading exterior cell '5, -11'
openmw: /usr/local/include/OGRE/OgreSharedPtr.h:160: T* Ogre::SharedPtr<T>::operator->() const [with T = Ogre::Skeleton]: Assertion `pRep' failed.
Application abort
It's not raised by OMW itself, but by the OGRE, and looks very strange.
Zini wrote: No idea about the NPC rendering (though that certainly has nothing to do with lag, since there is no real lag in OpenMW). The person to ask about it would be jhooks. But the crash is mentioned in the release posting. We are aware of it.
Master-X wrote: And a last question before I begin to read code crefully.
My CharGen GUI is almost completely black and absolutely useless. Is it normal for current stage of development?
Here is a link to the screenshot with CharGen GUI and my initial position shown.
http://s001.radikal.ru/i193/1101/a5/48b5f3940d98.jpg
jhooks1 wrote: About the npcs, that is just the way the constants (translations, rotations) are set up, if I worked on it longer it would have looked more proper. There is no point in fixing it now though since the SceneNode solution is being replaced with skeletons.
Zini wrote:
And a last question before I begin to read code crefully.
My CharGen GUI is almost completely black and absolutely useless. Is it normal for current stage of development?
Here is a link to the screenshot with CharGen GUI and my initial position shown.
http://s001.radikal.ru/i193/1101/a5/48b5f3940d98.jpg
That looks very wrong. Never seen it before. System specs please. Also, does that happen only for this window or for all of them (including stats window; press I to bring it up).
Master-X wrote: There is a shot of inventory window and NPCs lag:
http://s005.radikal.ru/i209/1101/42/609a2df1e86c.jpg

System specs:

Linux Aptosid x86 (rolling release) kernel 2.6.37-0.slh.4-aptosid-686 #1 SMP PREEMPT Wed Jan 12 17:29:12 UTC 2011 i686
Ogre 1.7.2 built from source without any problems
NVidia driver 195.36 (I know it's quite old, but it works fine with all my 3d programs, include original Morrowind and Oblivion under WINE)

Hardware:
Intel Core2Duo E7500 CPU, 3GB RAM
Nvidia GF9800GT with 1GB on board
Zini wrote: Seems to be a font problem. Are there any font-related messages in the OGRE log?
Master-X wrote: As far as I can see - nope.
There is a link to full log:
http://pastebin.com/CszBwT2N
Zini wrote: Only just noticed, that numbers are rendered correctly in your screenshot. So it is definitely not a font problem.

Well, I am stumped. Might be MyGUI related. But with the problem not reproducible on my system, I have no idea where to start. Maybe one of our MyGUI gurus can chip in.
Anonymouse wrote: Maybe this trouble is related to russian version of Morrowind?
Zini wrote: That would be an explanation. Currently OpenMW doesn't support international versions of Morrowind very well.
Master-X wrote: Ok. I can try with original Morrowind.esm.
best regards,
Lukasz

Locked

Who is online

Users browsing this forum: No registered users and 2 guests