The application was unable to start correctly (0xc000007b)

Support for running, installing or compiling OpenMW
User avatar
Site Admin
Posts: 1193
Joined: 05 Aug 2011, 22:21
Location: Wroclaw, Poland

The application was unable to start correctly (0xc000007b)

Post by lgromanowski » 15 Aug 2011, 13:29

mrlemonyfresh wrote: I've got the required dll's, I have the latest copy of Microsoft visual c for my 64bit version of windows 7...

And I get this error:

openmw.exe - Application Error

'The application was unable to start correctly (0xc000007b). Click OK to close the application.'

I can't find the solution on the forums or on google.

Thanks in advance.
Zini wrote: From your description it seems you have compiled OpenMW yourself. Did you mix up Debug and Release mode somewhere? That is a common problem on Windows.
mrlemonyfresh wrote: Actually I just downloaded the binary release :?

I had to add in the 2 Microsoft visual c DLLs and the open al one though.
Zini wrote: Still sounds like a mismatch to me. But I don't know enough about Windows and MSVC to help you any further. You will have to wait until one of our Windows developers steps in.
Hircine wrote: is there an actual binary release for the 0.08 milestone? i thought the last relz was for the D version.

maybe your better off getting all the dependencies and compiling it yourself.
Hircine wrote: have you tried running openmw thru the command line, it should output a better message than what you got.
Star-Demon wrote: If the application doesn't start, it means you didn't even get the first-time OGRE window. More than likely it's a library problem, if it's not something with your system itself.

Sorry I can't be more helpful - the error is a hex memory address that happened to store the instruction in the binary that the program failed on - I don't know how to print a stack trace for that.
mrlemonyfresh wrote: Thanks for the help anyway, has anyone else managed to get it running on windows 7 64 bit?
Hircine wrote: yes i have managed to get it running on Win 7 Ultimate 64bit.

I have you tried my suggestion of running it through the commandline to see what extra errors are made?
mrlemonyfresh wrote: Sorry, how do I do that?
Hircine wrote: type cmd into "search program and files" when you go into the start menu.

type cd "directory of openmw"

best to copy the directory you want and the right click on the command line and click paste.

so for instance mine would be

Code: Select all

cd C:\Program Files (x86)\Bethesda Softworks\Morrowind
then hit enter. this changes the directory.

then type openmw and hit enter

then give us the output of the command prompt.

mrlemonyfresh wrote: There was no output on the cmd window :/ just the same error in a message box.

however I noticed you've put OpenMW in the same folder as morrowind, I didn't think that was mandatory? I also noticed you have them in the x86 folder, mine is in the regular program files folder, could that be the problem?
Hircine wrote: nah i did it, because i could.

im pretty sure you don't need it, just so long the cfg file is correctly pointing to it.
mrlemonyfresh wrote: Ok I'll try compiling it, what do I need?

EDIT: BTW, just thought you guys might wanna know, I've been taking interest in the project because I'm waiting for a new handheld console called open Pandora which promises to have the capabilities to run such a port. I can't tell you specifically WHAT it has that's needed, but some more technically minded people of the forum have assured me it's possible, so I wanted to find out where the project is currently at.
Hircine wrote: LOL

had a bit of a discussion about it there.
but it will be looked at after a 1.0 release.
the main thing was thought of as a problem of doing it is OGRE OpenGLES support.

its not impossible, just really improbable for pre 1.0.
we can ask people after that over at Pandora forums or something to get some help porting it.

what you will need for compiling, is the dependencies, ... ment_Setup

check that

if you have a linux comp, or can dual boot into it, it might be easier compiling on it rather than windows.

hth. :)
mrlemonyfresh wrote: Aah.. would it it asking too much if I asked for you to send a zipped archive of your OM files?
Hircine wrote: for windows, i haven't compiled mine, i have just used the binaries provided on SF.

do you want the binaries that i am using? (which is pointless)
or did you mean something else?
werdanith wrote:
mrlemonyfresh wrote:I had to add in the 2 Microsoft visual c DLLs and the open al one though.
I assume these 2 DLLs where msvcr100.dll and msvcp100.dll ?
And when you say you had to add them, I assume you simply downloaded them separate and dropped them either in the system folder or the game folder?
That's what I did the first time and it didn't work. The way to solve this was to download the Microsoft Visual C++ 2010 Redistributable Package from their website: ... laylang=en
and install it and that solved my problems.
Although I don't remember seeing your specific error message and as you can see I made a few assumptions about your case, so I might be completely off base here.

Also worth noting is that I didn't have to install the OpenAL library (I had it installed already) and maybe it's a similar issue there, specifically that you have to install the packaged installer and not download a specific DLL (assuming again that that's what you did).

Anyway that's my five cents, you can try these first in case you haven't and post your results, because I am warning you, building the game from source for a non developer (on Windows especially) is going to be a long bumpy road.

As for me, once I got the Windows version to work and saw that I wasn't missing anything (due to drivers etc.) I jumped right back to my Ubuntu, more up-to-date version. :D
mrlemonyfresh wrote: Yes I installed that but I had to go to where it was installed, copy the dlls and place them in my OM directory. So yeah, everything should work..
Star-Demon wrote:
mrlemonyfresh wrote:Thanks for the help anyway, has anyone else managed to get it running on windows 7 64 bit?
yeah, worked fine for me when we had a recent release - about to see if I can bang out a quick video with a new install.
mrlemonyfresh wrote: So your making a tutorial I gather, awesome.
Star-Demon wrote:
mrlemonyfresh wrote:So your making a tutorial I gather, awesome.
Well, I wasn't thinking of video tutorial , but now that you mention it, it doesn't seem like a bad idea.

Problem is the only application I know of that can cap the screen without flipping display modes first is some sort of XNA studio application that was put out to encourage developers to make tutorials, and I haven't been able to find it since it was first shown to me by a friend doing windows Phone stuff. Otherwise I would be showing off my own XNA projects.
best regards,