CTD - 0.08 - Almost instant

Support for running, installing or compiling OpenMW
Locked
User avatar
lgromanowski
Site Admin
Posts: 1193
Joined: 05 Aug 2011, 22:21
Location: Wroclaw, Poland
Contact:

CTD - 0.08 - Almost instant

Post by lgromanowski » 15 Aug 2011, 12:50

Greendogo wrote: Solved - Needed to change the stupid path to "Data Files". Explained below.

Hey all, I didn't want to mar the announcement with my problem.

So I started OpenMW, selected the DX9 option and pushed start. It then went from black screen to desktop maybe twice and then exited with no pop-up error.
Here's a link to my Ogre.log

Edit: The same happens for OpenGl

Edit 2: My Data Files path is: "data=C:\Morrowind\Data"
I figure that the "Data Files" doesn't need the word " Files" in it since I don't think OpenMW likes spaces much in file paths. I thought ya'll were going to add a dialogue for that, btw?
nicolay wrote: Love how all the bugs are popping up right after release :)

Could you try running it in a console / terminal and see what output you get? We still haven't moved to using such newfangled methods as GUI windows for error messages yet (although that would be a good idea come to think of it.)
Greendogo wrote:

Code: Select all

ERROR: boost::filesystem::basic_directory_iterator constructor: The system cannot find the path specified: "c:\morrowind\data"
That fixed it. When I first tried it out I had "C:\morrowind\data files", but it didn't work, so I thought it needed it without the "files", so I took that out, but no dice. It works now of course. Now that I did the same thing twice, it works.

Shouldn't the default location be "data=data files" and not "data=data"?
Also, add a dialogue! It should be so easy! :D
EmbraceUnity wrote: Can you still do a symlink to the Data Files folder?

I am getting the following:

Code: Select all

~/openmw-0.08$ ./openmw
Data directory: ~/openmw-0.08/data
Segmentation fault (core dumped)
Granted, I had switched everything in that folder to be lowercase at one point... dunno if that is an issue.

EDIT: Ok, the issue was a bad build because cmake had cached an out-of-date OGRE location. A clean install fixed this.
best regards,
Lukasz

Locked