Ubuntu compiling issues

Support for running, installing or compiling OpenMW
Locked
User avatar
lgromanowski
Site Admin
Posts: 1193
Joined: 05 Aug 2011, 22:21
Location: Wroclaw, Poland
Contact:

Ubuntu compiling issues

Post by lgromanowski » 15 Aug 2011, 11:29

zzz wrote: Receiving an error while compiling on Ubuntu 8.04.
../bsa_file.hpp:27:36: error: mangle/stream/stream.hpp: No such file or directory

Current line:
#include <mangle/stream/stream.hpp>

Correction to compile on my system:
#include "../mangle/stream/stream.hpp"

Whats going on here?
zzz wrote: also another show stopper on Ubuntu
old:
//#include <libavcodec/avcodec.h>
//#include <libavformat/avformat.h>
new:
#include <ffmpeg/avcodec.h>
#include <ffmpeg/avformat.h>
Zini wrote: I can not confirm the first bug. Builds without problems here (Ubuntu 9.04).

No idea about the second. But the source you are mentioning is not part of the cmake build system yet, which means it is pretty old code, that is probably not fully supported at the moment. At least it is not part of the openmw executable.
zzz wrote: Thanks for following up on the post.

The pathing issues for all of the local #include paths have this issues.
If I correct them all, then it compiles fine.
There is one other issue with creation of an "archive" object but I do not remember the exact location or message. I commented it out and it will finish compiling. (I will look at it later and update you.)


Should I be seeing any video test? (skeleton?) I see a box popup, but it quickly closes...

Anyways good work Nico / Zini / etc. It is coming along nicely.
zzz wrote: adopted my handle...
Zini wrote: Well, there is obviously a problem with your setup. If you have to change the code, you are doing something wrong elsewhere. The archive problem is also very serious. Commenting the code out won't do you any good. Also, the window shouldn't close immediately. We already have interior cell rendering and basic WASD-navigation.
But without further information I have no idea how to help you.
btw. about which version of OpenMW are we talking here? 0.07? Or an up-to-date snapshot from the git-repository?
zzz wrote: This was an attempt to compile the latest release from the git source.
I delete my openmw directory and pulled a fresh copy and also a fresh copy of the mangle submodule. Then I added back the data directory.

I must have the wrong version of make or gcc.... let me research and I will try to post what I have.

Thanks for the help!
zzz wrote: Ubuntu 8.04
Linux 2.6.24-28-generic i686 GNU/Linux
GNU Make 3.81
/lib/libc-2.7.so
ogre-v1-6-2
CEGUI-0.6.0
ois_1.2.0
zzz wrote: oops forgot gcc

gcc (GCC) 4.2.4 (Ubuntu 4.2.4-1ubuntu4)
zzz wrote: Alright, I was going about it all wrong. I was getting a copy of the git repository and the trying to run the ./testall.sh.

Instead I followed the instructions on the Wiki. Creating the Build directory and then running cmake.(which I also update to version 2.6.4)

All the path issues currently appeared to go away, but the Archive error is still happening. (see below)

[ 57%] Building CXX object extern/caelum/CMakeFiles/caelum.dir/src/GroundFog.cpp.o
Linking CXX static library libcaelum.a
[ 57%] Built target caelum
Scanning dependencies of target openmw
[ 60%] Building CXX object CMakeFiles/openmw.dir/components/bsa/bsa_archive.cpp.o
/openmw/components/bsa/bsa_archive.cpp: In member function â??virtual Ogre::Archive* BSAArchiveFactory::createInstance(const Ogre::String&)â??:
/openmw/components/bsa/bsa_archive.cpp:142: error: cannot allocate an object of abstract type â??BSAArchiveâ??
/openmw/components/bsa/bsa_archive.cpp:37: note: because the following virtual functions are pure within â??BSAArchiveâ??:
/usr/local/include/OGRE/OgreArchive.h:131: note: virtual Ogre::DataStreamPtr Ogre::Archive::open(const Ogre::String&) const
make[2]: *** [CMakeFiles/openmw.dir/components/bsa/bsa_archive.cpp.o] Error 1
make[1]: *** [CMakeFiles/openmw.dir/all] Error 2
make: *** [all] Error 2
athile wrote: I'm on Windows, but I've been using OGRE 1.7.1. I believe 1.7 is a requirement.
zzz wrote: Hmm.... Did not know the project had moved to ogre 1.7.

Zini could post your library versions.
Zini wrote: 1.7.1.

And yes, athile is right. OpenMW doesn't work with Ogre 1.6.
ap0 wrote: I'm using :
- gentoo x64
- gcc 4.4.3-r2
- make 3.81
- ois 1.2.0

With ogre 1.6.2 :
openmw won't compile : i've got the same error as zzz above.

With ogre 1.7.1
openmw successfully compile !
best regards,
Lukasz

Locked