Search found 9 matches

by bably
30 May 2019, 05:36
Forum: Support
Topic: Crash on launch, related to playing video
Replies: 5
Views: 594

Re: Crash on launch, related to playing video

Hi akortunov,

I'm sending the crash log as an attachment.
by bably
30 May 2019, 04:52
Forum: Support
Topic: Crash on launch, related to playing video
Replies: 5
Views: 594

Re: Crash on launch, related to playing video

Hello again AnyOldName3, I'll answer both your replies here to avoid having to go back and forth between those threads :) For the dependencies: I didn't compile anything in the first place, so I figured that an apt-get update + apt-get install of the libs listed in this section of the Developer Envi...
by bably
29 May 2019, 23:33
Forum: Support
Topic: Crash on launch, related to playing video
Replies: 5
Views: 594

Crash on launch, related to playing video

Hello o/ So, as I mentioned in this thread , after compiling successfully a very recent commit from 0.46, my game is crashing when I press the "Play" button from the launcher. For some info: I'm using Ubuntu 18.04 on a 32 bit architecture, with an ARM processor (it's a chroot running in a chromebook...
by bably
29 May 2019, 23:06
Forum: Support
Topic: Failing to compile OpenMW on ARM
Replies: 10
Views: 1049

Re: Failing to compile OpenMW on ARM

So, I've dedicated some time to this today, and got a bit ahead in the process. I found out I could get a new version of the mesa drivers if I updated my chroot from Ubuntu 16 to 18, and that's what I did. This allowed me to get the mesa drivers versions 18.2.8, where the bug I was having had alread...
by bably
26 May 2019, 06:07
Forum: Support
Topic: Failing to compile OpenMW on ARM
Replies: 10
Views: 1049

Re: Failing to compile OpenMW on ARM

By digging around some more, I think that this is actually a bug within OpenGL and not OpenMW... From what I understood from the last link, it looks like this bug was fixed in Mesa 18.2.5, but mine is still 18.0.5 (is there a way to update this?). https://github.com/KhronosGroup/OpenGL-Registry/issu...
by bably
25 May 2019, 16:13
Forum: Support
Topic: Failing to compile OpenMW on ARM
Replies: 10
Views: 1049

Re: Failing to compile OpenMW on ARM

I don't remember messing around with OpenGL or OpenGLES, but it could be. Is there any way to check if this is the case? I'm no expert, but it looks like Qt has its own version of OpenGL (qopengl), which is clashing with the one used by OSG. I'll try with a fresh crouton install in the meanwhile. Up...
by bably
25 May 2019, 02:04
Forum: Support
Topic: Failing to compile OpenMW on ARM
Replies: 10
Views: 1049

Re: Failing to compile OpenMW on ARM

Thanks Miroslav, I was able to get pas the cmake step with that argument. However, I'm still stuck at the same point once I run make, with a slightly different message: [ 0%] Built target osg-ffmpeg-videoplayer [ 0%] Built target local_tinyxml [ 0%] Built target oics [ 0%] Building CXX object extern...
by bably
25 May 2019, 01:46
Forum: Support
Topic: Failing to compile OpenMW on ARM
Replies: 10
Views: 1049

Re: Failing to compile OpenMW on ARM

Hey AnyOldName3, So, I've purged Qt4 and installed Qt5, but the cmake step now tells me I need Qt4 instead of Qt5... I get the following output: -- Configuring OpenMW... -- Using Qt4 CMake Error at /usr/share/cmake-3.5/Modules/FindQt4.cmake:1326 (message): Found unsuitable Qt version "5.5.1" from /u...
by bably
24 May 2019, 23:24
Forum: Support
Topic: Failing to compile OpenMW on ARM
Replies: 10
Views: 1049

Failing to compile OpenMW on ARM

Hi everyone :) I've been trying to run openmw on my ARM laptop these past few days. It's an ARMV7L, running Ubuntu 16.04.6 in a chromebook, using crouton. I cloned the repo a few hours ago, the last commit that shows up w/ git log is: Merge branch '2' into 'master' (e0fb411fc80f50d32fd98dcbef5c8974b...